Closed Bug 1386575 Opened 2 years ago Closed 2 years ago

Photon customization-header styles get (presumably) spilled into cedar/56

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 56
Iteration:
57.1 - Aug 15
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 + fixed
firefox57 --- unaffected

People

(Reporter: johannh, Assigned: johannh)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-structure][p2])

Attachments

(1 file)

After a conversation with Gijs on IRC we found that the ifdef in https://hg.mozilla.org/mozilla-central/rev/99e8731d94f0 is wrong in two ways:

- It should be an ifndef
- It presumably always evaluates to false because of the trailing semicolon

This will make the customize mode header in 56 always have Photon style.
Flags: qe-verify+
Comment on attachment 8892827 [details]
Bug 1386575 - Fix ifdef in customization-header styles.

https://reviewboard.mozilla.org/r/163816/#review169158
Attachment #8892827 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8892827 [details]
Bug 1386575 - Fix ifdef in customization-header styles.

https://reviewboard.mozilla.org/r/163816/#review169170

::: commit-message-52285:1
(Diff revision 1)
> +Bug 1386575 - Fix ifdef in customization-header styles. r=Gijs

Opening an issue in an attempt to prevent this from landing on m-c, as this would make me have to wait until this gets merged around for me to rebase and land bug 1349555.

This should land on beta, though.
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b0ff9d96586a
Fix ifdef in customization-header styles. r=Gijs
QA Contact: gwimberly
Whiteboard: [photon-structure][p2] → [reserve-photon-structure][p2]
Track 56+ as regression.
Comment on attachment 8892827 [details]
Bug 1386575 - Fix ifdef in customization-header styles.

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1354145.
[User impact if declined]: Not critical, the header font in the customize mode will already have Photon style even though we only wanted to turn it on in 57.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: No, we backed it out of central because the ifdef got removed separately by bug 1349555.
[Needs manual test from QE? If yes, steps to reproduce]: I don't think so.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Nope
[Why is the change risky/not risky?]: Fixes an ifdef in a CSS file.
[String changes made/needed]: None
Attachment #8892827 - Flags: approval-mozilla-beta?
Comment on attachment 8892827 [details]
Bug 1386575 - Fix ifdef in customization-header styles.

Minor style fix, let's uplift this for 56 beta 1.
Attachment #8892827 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/472bdbe54b17
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Iteration: --- → 57.1 - Aug 15
Bah - this is something that screenshots on Cedar compared to beta would have (hopefully) caught if I'd ever gotten it working. :/ Sorry, folks.
You need to log in before you can comment on or make changes to this bug.