Closing the pre-filled log in form and opening a new one will display empty address

RESOLVED WONTFIX

Status

()

Firefox for Android
Firefox Accounts
RESOLVED WONTFIX
4 months ago
3 months ago

People

(Reporter: Ninu, Unassigned)

Tracking

55 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox56 affected)

Details

(Whiteboard: [fxa])

(Reporter)

Description

4 months ago
Device: Samsung Galaxy S6 EDGE 
OS: Android 7.0

STR:

On desktop
1. Create new FxA on desktop client
2. Send SMS install link to Mobile user
On mobile: 
3. Close the address prefilled login form
4. Go to settings-Sign in

Expected: Email address prefilled
Actual : Empty address field

For further details please check: https://www.youtube.com/watch?v=aRVjUd9cAGs&feature=youtu.be
Component: QA: General → Firefox Accounts
Product: Cloud Services → Firefox for Android
Whiteboard: [fxa]
Version: unspecified → 55 Branch

Comment 1

3 months ago
Since sign-in codes are single-use, is this more-or-less working as intended?
Flags: needinfo?(stomlinson)
(In reply to Ryan Kelly [:rfkelly] from comment #1)
> Since sign-in codes are single-use, is this more-or-less working as intended?

Yes. We could possibly do something clever like store the email address in localStorage after a signinCode is consumed, but TBH, I'm a bit "meh."
Flags: needinfo?(stomlinson)

Comment 3

3 months ago
I agree, we should optimize for providing a good experience on the deeplink, but given the cost of refactoring this, I think we can live with the described behaviour where it "forgets" the email address if you close that screen.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.