Update calendar eslint config after rules moved from toolkit

RESOLVED DUPLICATE of bug 1346797

Status

defect
RESOLVED DUPLICATE of bug 1346797
2 years ago
2 years ago

People

(Reporter: rkent, Unassigned)

Tracking

Lightning 4.1

Details

Reporter

Description

2 years ago
In Bug 1359011, mozilla/toolkit was removed as the canonical source of linting rules in m-c, but calendar/.eslintrc.js still extends from that location.

The mozilla linting is still undergoing rapid changes, so that new rules are being enabled in the mozilla-central general linting rules regularly. Those fixes in m-c are not being ported to /calendar.

We have a choice: switch calendar to the changing m-c default, or create our own rules starting from what was enabled when calendar linting was first completed. The former will result in new linting failures in calendar whenever there are new rules added to m-c.

I suggest that we instead create our own rule list, get calendar error-free again, then only add new rules from the general m-c set when we are prepared to actually fix the failures in linting in calendar.
Reporter

Updated

2 years ago
Summary: Update calendar eslint config after rules moved from tools → Update calendar eslint config after rules moved from toolkit
In bug 1346797 I am moving to use the mozilla:recommended plugin, which will obviously cause some failures over time. I think we should see how this goes, and if there are things we need to disable because the rule change would take a while to fix, we can do this quickly.

If that becomes too clunky, we can remove the plugin and fork the rules.

Note also that bug 1346797 fixes all issues. The massive amount of indent issues you saw is due to the eslint xbl processor not being flexible enough, I have a bug filed to fix this.
This is fixed now
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1346797
You need to log in before you can comment on or make changes to this bug.