Closed Bug 1387046 Opened 3 years ago Closed 3 years ago

CompositorOptions operator== doesn't check advanced layers flag

Categories

(Core :: Graphics, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: kats, Assigned: kats)

References

Details

Attachments

(1 file)

Spotted this while reading code
Comment on attachment 8893383 [details]
Bug 1387046 - Add missing field to operator== in CompositorOptions.

https://reviewboard.mozilla.org/r/164498/#review169868
Attachment #8893383 - Flags: review?(dvander) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3758e58e7846
Add missing field to operator== in CompositorOptions. r=dvander
https://hg.mozilla.org/mozilla-central/rev/3758e58e7846
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Comment on attachment 8893383 [details]
Bug 1387046 - Add missing field to operator== in CompositorOptions.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1365879
[User impact if declined]: unsure, probably nothing. it might result in subtle errors when advanced layers is toggled because the state might not get propagated properly.
[Is this code covered by automated tests?]: yes
[Has the fix been verified in Nightly?]: there's no STR or visible issues, so nothing to verify really
[Needs manual test from QE? If yes, steps to reproduce]: no
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: trivial correction
[String changes made/needed]: none
Attachment #8893383 - Flags: approval-mozilla-beta?
Comment on attachment 8893383 [details]
Bug 1387046 - Add missing field to operator== in CompositorOptions.

A trivial fix. Should be low risk. Beta56+. Should be in 56 beta 2.
Attachment #8893383 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.