One-touch-pinch zoom in and out is janky/jumpy

RESOLVED FIXED in Firefox 57

Status

()

Firefox for Android
Toolbar
P2
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: abovens, Assigned: kats)

Tracking

55 Branch
Firefox 57
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 disabled, firefox56 disabled, firefox57 fixed)

Details

(Reporter)

Description

5 months ago
Steps to reproduce:
Double-tap-drag zoom in and out (and repeat a few times). 

Expected result
Smooth zoom in and out, and page ends up in the same position.

Actual result
When the zooming works, there is a lot of checkerboarding going on (white flashing areas), and sometimes the page's coordinates seem to jump around / be reset to 0,0. In some instances, the page display is completely broken, and a refresh is required to continue browsing.

Environment:
Firefox 55 beta on Nexus 6P
(Assignee)

Updated

5 months ago
Blocks: 1111333
status-firefox55: --- → affected
status-firefox56: --- → affected
status-firefox57: --- → affected
Component: General → Graphics, Panning and Zooming
OS: Unspecified → Android
Priority: -- → P2
Hardware: Unspecified → All
(Assignee)

Updated

5 months ago
status-firefox55: affected → disabled
See Also: bug 1111333
Can you provide a specific URL on which you see this? The coordinates "snapping" is a preexisting issue that happens with regular pinch zooming as well, it is tracked by bug 1358771 (assuming that is what you are seeing, it's hard to tell from your description). A video would be quite valuable here.
Flags: needinfo?(abovens)
(Reporter)

Comment 2

4 months ago
Sure, I see it here: http://andreasbovens.github.io/understanding-viewport/noviewport.html
Flags: needinfo?(abovens)
(Assignee)

Updated

4 months ago
Depends on: 1391770
(Assignee)

Updated

4 months ago
Summary: Double-tap-drag zoom in and out is janky/jumpy → One-touch-pinch zoom in and out is janky/jumpy
I've landed a few fixes (including bug 1358771) to the one-touch-pinch behaviour since this bug was filed. Are you still seeing the janky/jumpy behaviour?
Flags: needinfo?(abovens)
(Reporter)

Comment 4

3 months ago
I see less jumpiness, but triggering one-touch-pinch zoom is still inconsistent. It typically works 1 time out of 5 or so.
Flags: needinfo?(abovens)
That's bug 1387055, so I'll close this one.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → FIXED
status-firefox56: affected → disabled
status-firefox57: affected → fixed
Assignee: nobody → bugmail
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.