Reland the LZMA and SHA384 mar generation scripts after 56 Beta 3

RESOLVED FIXED in Firefox 56

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: rstrong, Unassigned)

Tracking

unspecified
mozilla56
Points:
---

Firefox Tracking Flags

(firefox56+ fixed)

Details

Bug 1387231 will backout the LZMA and SHA384 mar generation script changes on 56 Beta. They should be relanded on 56 Beta after Beta 3.

Specifically, the following from bug 1385780
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/f632eede0f19
Update mar file generation scripts for lzma. r=bhearsum, r=rail, a=app_update_lzma
https://hg.mozilla.org/mozilla-central/rev/bbd46c077793
Update mar file generation scripts for lzma. r=bhearsum
https://hg.mozilla.org/mozilla-central/rev/7f9ed540c827
New mar convertor script to convert a mar file from bzip2 to lzma and from lzma to bzip2. r=bhearsum, a=app_update_lzma
https://hg.mozilla.org/mozilla-central/rev/87824406b9fe
sign mar files using the sha384 certificate. r=bhearsum, a=app_update_sha384

At the same time the patch in bug 1386402 should land on 56 Beta as well.
Tracking for 56 since we intend to land this later in beta.
status-firefox56: --- → affected
tracking-firefox56: --- → +
Ryan, can you reland the patches mentioned in comment 0, on beta for today's beta 4 build? Thanks.
Flags: needinfo?(ryanvm)
Approval Request Comment
[Feature/Bug causing the regression]: Not a regression. This is for the build scripts changes to support lzma and sha384 in bug 1385780 that were backed out so we had assurance that beta builds were stable
[User impact if declined]: Users won't be able to update beyond beta 3
[Is this code covered by automated tests?]: These are releng scripts for mar generation. The scripts have been used to create mar files used by tests so in a manner they are tested.
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None needed but bug 1386402 is related
[Is the change risky?]: No
[Why is the change risky/not risky?]: We have been using this on nightly to generate mar files.
[String changes made/needed]: None
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #2)
> Ryan, can you reland the patches mentioned in comment 0, on beta for today's
> beta 4 build? Thanks.
I can take care of this along with a couple of other patches I need to land
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.