Closed Bug 1387273 Opened 4 years ago Closed 4 years ago

Small gap above tabs when window is not maximized

Categories

(Firefox :: Theme, defect, P1)

Unspecified
Windows 10
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.2 - Aug 29
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- disabled
firefox57 --- verified

People

(Reporter: asa, Assigned: johannh)

References

Details

(Keywords: polish, regression, Whiteboard: [photon-visual][p1][fixed by 1375335])

Attachments

(1 file)

There is a several pixel gap above the tabs for non-maximized windows. There should be no gap above the tabs (until bug 1349552 is implemented). 

The steps to reproduce elude but it seems to happen when going from maximized to restored and may require some tab bar customization to trigger.
This is almost certainly due to the caching and/or calculations in browser-tabsintitlebar.js .
Blocks: 1349555
Component: Toolbars and Customization → Theme
Keywords: regression
Whiteboard: [photon-visual] → [photon-visual][triage]
Depends on: 1375335
Duplicate of this bug: 1387423
Duplicate of this bug: 1387567
Duplicate of this bug: 1387655
Duplicate of this bug: 1387985
Duplicate of this bug: 1388261
Priority: -- → P1
Whiteboard: [photon-visual][triage] → [photon-visual][p1]
Flags: qe-verify?
Priority: P1 → P2
Anyone able to reproduce this more consistently? is it particular to any platform? could take a look at this but I havent been able to reproduce at all
(In reply to Dale Harvey (:daleharvey) from comment #7)
> Anyone able to reproduce this more consistently? is it particular to any
> platform? could take a look at this but I havent been able to reproduce at
> all

Some of the duplicates have better steps to reproduce, e.g. bug 1387655 comment 0.

This should probably wait for bug 1375335 though.
STR
1. Start with clean profile
2. Maximize browser if not
3. Restore window size to normal
   --- observe the bug, extra border appears
4. Open new window
5. Compare the width of the top border

(If a dark / bright theme is applied, you can recognize it more easily)
OS: Unspecified → Windows 10
Yes, Bug 1375335 fixes the problem on Windows10.
Marking this as resolved fixed by bug 1375335 based on comment 10 and my own observation. Asa, feel free to re-open if it's not fixed for you after the next Nightly update.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Whiteboard: [photon-visual][p1] → [photon-visual][p1][fixed by 1375335]
Iteration: --- → 57.2 - Aug 29
Priority: P2 → P1
Assignee: nobody → jhofmann
Target Milestone: --- → Firefox 57
I have reproduced this bug with Nightly 57.0a1 (2017-08-03) on Windows 8.1, 64 Bit!

This bug's fix is verified on Latest Nightly 57.0a1.

Build ID : 20170817100132
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20170816]
Flags: qe-verify? → qe-verify+
QA Contact: ovidiu.boca
I verified this issue on Windows 10 with Nightly 57.0a1(2017-08-22) and I can't reproduce this.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.