Closed Bug 1387359 Opened 2 years ago Closed 2 years ago

Devtools menu empty after starting firefox with --jsconsole

Categories

(DevTools :: General, defect, P3)

defect

Tracking

(firefox56 verified, firefox57 verified)

VERIFIED FIXED
Firefox 57
Tracking Status
firefox56 --- verified
firefox57 --- verified

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

(Keywords: regression)

Attachments

(1 file)

Regression from Bug 1359855

STRs:
- ./mach run --jsconsole
- in the hamburger menu, open the developer menu 

ER: Menu is not empty
AR: Menu is empty. (When  testing without photon, the developer button is simply not displayed)
Comment on attachment 8893718 [details]
Bug 1387359 - add developer toggle to CustomizableUI even if devtools already loaded;

https://reviewboard.mozilla.org/r/164832/#review170276

The patch looks reasonable to me, and is working on a clean profile.
Attachment #8893718 - Flags: review?(nchevobbe) → review+
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/95a0b91cbd34
add developer toggle to CustomizableUI even if devtools already loaded;r=nchevobbe
https://hg.mozilla.org/mozilla-central/rev/95a0b91cbd34
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I can reproduce this bug following STR from comment 0, with Nightly 57.0a1 (2017-08-04) in 64bit Linux

I can verify that this bug is fixed in latest nightly 57.0a1

Build ID 	20170806100257
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20170802]
Comment on attachment 8893718 [details]
Bug 1387359 - add developer toggle to CustomizableUI even if devtools already loaded;

Approval Request Comment
[Feature/Bug causing the regression]: Bug 1359855
[User impact if declined]: users starting firefox with the command line argument "--jsconsole" will have empty DevTools menus.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: yes
[Needs manual test from QE? If yes, steps to reproduce]: 
yes, see bug summary for STRs
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: no
[Why is the change risky/not risky?]: Has been on central for a few days. Is a simple javascript fix that only impacts devtools menu creation.
[String changes made/needed]: none
Attachment #8893718 - Flags: approval-mozilla-beta?
Hi Brindusa, could you help find someone to verify if this issue was fixed as expected on the latest Nightly build? Thanks!
Flags: needinfo?(brindusa.tot)
Comment on attachment 8893718 [details]
Bug 1387359 - add developer toggle to CustomizableUI even if devtools already loaded;

This needs to land first for the uplift in bug 1386821 (for dev tools toolbar visibility).
Attachment #8893718 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
I managed to reproduce the issue on an older Nightly 57.0a1 (2017-08-03) build under Windows 10 x64.
Verified as fixed using latest Nightly 57.0a1 (2017-08-17) on Ubuntu 14.04 x64, Windows 10 x64 and Mac OS X 10.12
Status: RESOLVED → VERIFIED
Flags: needinfo?(brindusa.tot)
Also was able to reproduce the issue on old Nightly 57.0a1 (2017-08-03) and I verified that the issue is fixed using Firefox 56 beta 11 across platforms (Windows 10 64bit, Ubuntu 16.04 32bit and macOS 10.12.6).
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.