Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: bato3, Unassigned)

Tracking

({memory-footprint})

54 Branch
memory-footprint
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

Attachments

(2 attachments)

326.41 KB, application/x-zip-compressed
Details
914.19 KB, application/x-zip-compressed
bato3
: feedback+
Details
(Reporter)

Description

a year ago
Created attachment 8893771 [details]
about-memory.zip 4 memory reports

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36

Steps to reproduce:

Open page: https://czat3.shinden.pl/ff-ws.html (1-5 tabs) and observe groving memory.

Open connection to websocket (In my case Faye library) and send messages to server.

FF 54.0.1 (64 bity), 


Actual results:

Memory usage grows, and isn't free after closing tab. In my case, after couple hours FF memory consumption is ~3GB. Friend have crashes.


Expected results:

Better garbage collection
(Reporter)

Comment 1

a year ago
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0

After click all buttons in about:memory -> Free memory - it looks, that memory don't grows
Component: Untriaged → Networking: WebSockets
Keywords: footprint
Product: Firefox → Core
Whiteboard: [MemShrink]

Comment 2

a year ago
Those memory reports all look good, is it possible to provide one with the observed behavior?
Flags: needinfo?(bato3)
(Reporter)

Comment 3

a year ago
Created attachment 8896211 [details]
more_reports.zip

Heh, I hate situations like this. Now works for me... 

But yesterday I take info from another user about memory grows until crash FF. After disabling websocket transport - it looks OK.

In archive 2 sets memory dumps from live + prefs.js

I don't remember, but memory00[\n]-report is fresh FF run.
Flags: needinfo?(bato3)
Attachment #8896211 - Flags: feedback+
(Reporter)

Comment 4

a year ago
It turned out that after the lock ws still has a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.