Closed Bug 1387412 Opened 2 years ago Closed 2 years ago

Update pdf.js to version 1.8.605

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox55 --- unaffected
firefox56 ? fixed
firefox57 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1386113 +++

Changes since last update:
#8627 Fallback on font widths if CFF data is broken
#8681 Fix several issues with glyph id mappings (issue 8668, bug 1383504)
#8744 Checks Edge support for streams.
#8738 Delete workerPort to PDFWorker cache after PDFWorker destroy
#8745 Properly cancel streams and guard at getTextContent.
#8747 Fix two cmap related issues.
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/461a5fc977de
Update pdf.js to version 1.8.605. r=bdahl
https://hg.mozilla.org/mozilla-central/rev/461a5fc977de
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
This apparently fixes a regression in pdf.js that slipped in during the 56 cycle. I've been asked by bdahl to put this up for uplift approval.
Attached file uplift request
Approval Request Comment
[Feature/Bug causing the regression]: bug 1378866
[User impact if declined]: broken glyph rendering in some PDFs
[Is this code covered by automated tests?]: not as far as I can tell :(
[Has the fix been verified in Nightly?]: yes, by the reporter of bug 1383504
[Needs manual test from QE? If yes, steps to reproduce]: no, already verified by reporter
[List of other uplifts needed for the feature/fix]: none
[Is the change risky?]: low risk
[Why is the change risky/not risky?]: because that's what bdahl told me :)
[String changes made/needed]: none
Attachment #8894376 - Flags: approval-mozilla-beta?
To fill in some of the above:

> Approval Request Comment
> [Feature/Bug causing the regression]: bug 1378866
> [User impact if declined]: broken glyph rendering in some PDFs

We've only seen one reported case of the issue.

> [Is this code covered by automated tests?]: not as far as I can tell :(

This is now covered in tests in the github pdf.js project.

> [Has the fix been verified in Nightly?]: yes, by the reporter of bug 1383504
> [Needs manual test from QE? If yes, steps to reproduce]: no, already
> verified by reporter
> [List of other uplifts needed for the feature/fix]: none
> [Is the change risky?]: low risk
> [Why is the change risky/not risky?]: because that's what bdahl told me :)

There were minimal changes to pdf.js between updates and the change should only impact very few PDFs that have strange font issues.

> [String changes made/needed]: none
Comment on attachment 8894376 [details]
uplift request

Sounds useful for fixing some pdf.js issues, we're still early in beta, so let's take this.
Attachment #8894376 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Since this is fixed, no need to track it for 57.
Blocks: 1389211
You need to log in before you can comment on or make changes to this bug.