Remove test that expects click point to be at the element’s centre point

RESOLVED DUPLICATE of bug 1359043

Status

Testing
Marionette
RESOLVED DUPLICATE of bug 1359043
4 months ago
4 months ago

People

(Reporter: ato, Assigned: ato)

Tracking

Version 3
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 months ago
The
test_should_scroll_elements_if_click_point_is_out_of_view_but_element_is_in_view
test in TestClickScrolling is wrong because it assumes the click
point to be at the element’s centre point.

The WebDriver conforming Element Click implementations expects the
click point to be the _in-view_ centre point, and in preparation of
moving to this implementation, we want to drop this test.

This means that if parts of the element is rendered outside the
viewport, the click point is calculated from visible portion of the
element that is seen in the viewport.
(Assignee)

Updated

4 months ago
Assignee: nobody → ato
Blocks: 1321516
Status: NEW → ASSIGNED
(Assignee)

Updated

4 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1359043
You need to log in before you can comment on or make changes to this bug.