App Crashes after clicking on profile manager finish.

VERIFIED DUPLICATE of bug 13780

Status

P3
minor
VERIFIED DUPLICATE of bug 13780
19 years ago
3 years ago

People

(Reporter: cpratt, Assigned: troy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999091509
Platform: all

To reproduce:
- If they exist, delete your moz*.dat and Users50 folders/files
- Launch apprunner
- In the Profile Manager dialog that comes up, note that the Finish button is
present and active (ie not greyed out)
- Click on Finish

Result: The app crashes

Expected result: that button should not be active or clickable.

Updated

19 years ago
Assignee: selmer → gayatrib

Comment 1

19 years ago
Gayatri, is this really a crash or just an assertion?  If it's an assertion,
please dup it against the button disable bug we already filed.

Comment 2

19 years ago
*** Bug 13882 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
*** Bug 13900 has been marked as a duplicate of this bug. ***

Comment 4

19 years ago
There is a MAC stack trace in bug 13900.
(Reporter)

Comment 5

19 years ago
Win32 talkback incident report number is 13562158 - see also
http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=16&cp=1&ck1=
SUser+email+address&cd1=%25bear%40marmot%2Enet%25&co1=like&bbid=13562158

Comment 6

19 years ago
I checked in a fix to handle an untimely click on the finish button in the first
screen, without entering any profile info. However this bug is not related to
that. I am not sure that it is a profiles bug.

I doubt it very much, but Alec, Seth do you have any idea if the changes you
made to profile code is causing this? I think not, but just want to make sure.

Can you think of who would be appropriate to reassign it to?

Updated

19 years ago
Assignee: gayatrib → troy

Comment 7

19 years ago
Reassinging the bug to troy as the stack trace shows the problem to be occurring
in nsPresContext.cpp, owned by troy at the location of the bug. As this is not a
profiles bug, and it originates here, I am reassigning to you. Please reassign
appropriately if it does not belong to you.

Updated

19 years ago
Summary: Finish button active in first pane of Profile Manager → App Crashes after clicking on profile manager finish.

Comment 8

19 years ago
Here is the stack trace:
---------------------------------------
nsPresContext::PreferenceChanged(const char * 0x02322b90) line 252 + 19 bytes
PrefChangedCallback(const char * 0x02322b90, void * 0x01a30ac0) line 55
pref_DoCallback(const char * 0x02322b90) line 2313 + 17 bytes
pref_HashPref(const char * 0x02322b90, PrefValue {...}, int 32, int 0) line 1878
+ 9 bytes
PREF_SetDefaultCharPref(const char * 0x02322b90, const char * 0x02322b10) line
813 + 17 bytes
nsPref::SetDefaultCharPref(nsPref * const 0x00ab7670, const char * 0x02322b90,
const char * 0x02322b10) line 654 + 13 bytes
XPTC_InvokeByIndex(nsISupports * 0x00ab7670, unsigned int 38, unsigned int 2,
nsXPTCVariant * 0x0012e648) line 135
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x01b46b40,
nsXPCWrappedNative * 0x02322ec0, const XPCNativeMemberDescriptor * 0x00f2e518,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 2, long *
0x00e9be68, long * 0x0012e868) line 661 + 44 bytes
WrappedNative_CallMethod(JSContext * 0x01b46b40, JSObject * 0x01d3de38, unsigned
int 2, long * 0x00e9be68, long * 0x0012e868) line 170 + 34 bytes
js_Invoke(JSContext * 0x01b46b40, unsigned int 2, unsigned int 0) line 654 + 26
bytes
js_Interpret(JSContext * 0x01b46b40, long * 0x0012f098) line 2228 + 15 bytes
js_Invoke(JSContext * 0x01b46b40, unsigned int 0, unsigned int 0) line 670 + 13
bytes
js_Interpret(JSContext * 0x01b46b40, long * 0x0012f884) line 2228 + 15 bytes
js_Invoke(JSContext * 0x01b46b40, unsigned int 1, unsigned int 2) line 670 + 13
bytes
js_InternalCall(JSContext * 0x01b46b40, JSObject * 0x00e695d0, long 15774704,
unsigned int 1, long * 0x0012f9a0, long * 0x0012fa08) line 747 + 15 bytes
JS_CallFunctionValue(JSContext * 0x01b46b40, JSObject * 0x00e695d0, long
15774704, unsigned int 1, long * 0x0012f9a0, long * 0x0012fa08) line 2662 + 29
bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x01c084a0) line 110 + 43 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012fc8c, nsIDOMEvent * * 0x0012fb68, unsigned int 7, nsEventStatus &
nsEventStatus_eIgnore) line 991 + 21 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x01b46d04,
nsIPresContext & {...}, nsEvent * 0x0012fc8c, nsIDOMEvent * * 0x0012fb68,
unsigned int 1, nsEventStatus & nsEventStatus_eIgnore) line 2848
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x01b822e4, nsIDocumentLoader *
0x01b82260, nsIChannel * 0x02341320, unsigned int 0, nsIDocumentLoaderObserver *
0x01b822e4) line 3302 + 34 bytes
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x01b82260, unsigned
int 0) line 1103
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x01b82264, nsIChannel *
0x024cf490, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 974
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x01b82200, nsIChannel *
0x024cf490, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 576 + 39 bytes
nsFileChannel::OnStopRequest(nsFileChannel * const 0x024cf49c, nsIChannel *
0x024cf490, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 838
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x0249e8b0) line
269
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x0249e8b4) line 144 + 12 bytes
PL_HandleEvent(PLEvent * 0x0249e8b4) line 509 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ab7d60) line 470 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x011306cc, unsigned int 49295, unsigned int 0,
long 11238752) line 938 + 9 bytes
USER32! 77e713ed()
00ab7d60()
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 9

19 years ago
*** This bug has been marked as a duplicate of 13780 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

19 years ago
I'll buy that. BTW, the bug originally had to do with the Finish button being
active... that's covered somewhere else, yes, gayatrib?

Comment 11

19 years ago
Yes, the finish button is now covered. As disabling buttons is not working
properly (bug 13808), I have an alert box coming up to handle an early click on
the finish button now.

Updated

19 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 12

19 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.