Closed Bug 1387737 Opened 2 years ago Closed 2 years ago

Regression: Changing theme breaks default theme

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified

People

(Reporter: soeren.hentzschel, Assigned: ntim)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached video bug
STR:

1. enable another theme in add-on mananger
2. switch back to default theme

expected:

The default theme is applied again.

actual result:

the default theme does not look like the default theme.

Please see the attached screencast.
Duplicate of this bug: 1387880
Duplicate of this bug: 1387752
Duplicate of this bug: 1387751
Can someone try finding the regression window with mozregression, please?
Flags: qe-verify+
(In reply to Johann Hofmann [:johannh] from comment #4)
> Can someone try finding the regression window with mozregression, please?

Will look into it...
Have to say that the theme which is born from "Default > Dark > Default" doesn't look bad.
Confirmed that this broke in bug 1342712.
Has Regression Range: --- → yes
Has STR: --- → yes
Assignee: nobody → ntim.bugs
Flags: needinfo?(ntim.bugs)
The issue is pretty straightforward:

When switching back to the default theme, aData and parsedData are null. So the check for parsedData.window throws.
Comment on attachment 8894466 [details]
Bug 1387737 - Fix switching back to the default theme.

https://reviewboard.mozilla.org/r/165642/#review170722
Attachment #8894466 - Flags: review?(gijskruitbosch+bugs) → review+
Duplicate of this bug: 1388010
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/864b3a48a8f8
Fix switching back to the default theme. r=Gijs
Pushed by kwierso@gmail.com:
https://hg.mozilla.org/mozilla-central/rev/fde1450a4368
Fix switching back to the default theme. r=Gijs a=merge
https://hg.mozilla.org/mozilla-central/rev/fde1450a4368
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Duplicate of this bug: 1388175
Duplicate of this bug: 1388272
Duplicate of this bug: 1388186
Duplicate of this bug: 1388322
Fixed on latest Nightly.
Status: RESOLVED → VERIFIED
Managed to reproduce the issue on an affected build (Firefox 57.0a1), using the steps to reproduce from Comment 0, on Windows 10 X 64 bit. Hence the bug-1387737 is fixed & verified.
build ID: 20170809100326
[bugday-20170809]
You need to log in before you can comment on or make changes to this bug.