scroll tab-bar using < > arrows jerks & is slow

RESOLVED DUPLICATE of bug 1387130

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 1387130
7 months ago
6 months ago

People

(Reporter: Bill his name, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170805100334

Steps to reproduce:

Browse 
using Nightly 57.0a1 (2017-08-05) (32-bit) under windows10

Get several tabs (more than tab-bar horizontal allocation).

Use < > arrows at sides of tab list to scroll tabs (left or right)


Actual results:

Slowly, slowly, & jerkily
the tab-bar moves in tab-sized increments.
I  estimate  the  rate  to  be  700ms  per  tab

This.  languid.  sluggishness.  interrupts.  work flow.

Using mouse-wheel to scroll tabs remains acceptable smooth scroll. 

~~~~
Additionally, when horizontal scrolling inside a rendered page using keyboard arrows,
there is similar slow jerky behaviour.
Is this related?

~~~~
UX - Also, it is difficult to regain focus to current tab if tab is scrolled out of view.


Expected results:

When using < > arrows, tabs should scroll nicely at a usable rate.

Not too slow, not too fast, just right for everybody. Regardless of reaction times or impatience quotient.

Whether smooth or in tab-sized increments is a matter of personal preference for Users. 
IMO, the jerks do have potential for increasing precision.

{Where can one see, discuss & actually influence style points?}

~~~~
.. Similarly, so should web-pages scroll politely when using keyboard arrows. 
No jerks. 

~~~~
Adjunct: it should be easy to regain focus on current tab when it has moved.
Because one may need tab drop-down buttons.
(Reporter)

Updated

7 months ago
Duplicate of this bug: 1387760
(Reporter)

Comment 2

7 months ago
Additional to above, I notice intermittent behaviours.
Sometimes if I hold the "<", the tabs will move, but when I release the "<", they jump a further few places.
This is very unappealing.
(Reporter)

Comment 3

7 months ago
Possibly related difficulty regaining focus on current tab:
https://bugzilla.mozilla.org/show_bug.cgi?id=1387769

Updated

7 months ago
Component: Untriaged → Tabbed Browser

Comment 4

7 months ago
Probably a dupe of bug 1387084? Is this better in more recent nightlies?
Blocks: 1387084
Flags: needinfo?(billachenal)
(Reporter)

Comment 5

7 months ago
57.0a1 (2017-08-06) (32-bit) continues the behaviour.

Playing around, I did note that using < or > can cause quite erratic jumps, worse under conditions of load = many browser windows & many tabs (+ maybe youtubes as well). 
Running under win10, on an oldish laptop dell Latitude D520 (adequate, 4GB, Core2 CPU T5600 @ 1.83GHz
Works ok if I am cautious & caeful). I suspect less of a problem for more capable rigs.

+ I think there was a config item at one time to smooth-scroll tab-bar (which still happens if I use mousewheel); I wonder if that is/was relevant.
Flags: needinfo?(billachenal)

Comment 6

7 months ago
There's a regression range in bug 1388070, so duping there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1388070
(Reporter)

Comment 7

7 months ago
Moved relevant comments (comment 5 & above)to bug 1388070, so no need to revisit here.
(Reporter)

Comment 8

7 months ago
... which was again marked dup of 1387130, so moved comments there too. Perhaps it will rest there.
You need to log in before you can comment on or make changes to this bug.