Sidebar draws to left of toolbars

VERIFIED FIXED in M11

Status

SeaMonkey
Sidebar
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: cpratt, Assigned: german)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build ID: 1999091509
Platform: Windows NT (haven't installed this build on other platforms yet)

To reproduce:
- Launch apprunner

Result: The sidebar takes up the entire left hand side of the window; the
toolbars are to the right of it.

Expected result: The toolbars should stretch the whole length of the window; the
Sidebar should start beneath them. See IE 4/5 for a correct implementation.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 1

18 years ago
The sidebar to the left of the toolbars is the new design given by the UE team.
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

18 years ago
Oh. OK. Verifying invalid.

BTW, did anyone on the UE/UI team take in account what people are used to in
Web browsers? This new spec is different than IE 4.0 or 5.0 on Windows, and it's
different than IE 4.5 on the Mac OS. Is there any valid reason as to why we're
choosing to make it different than the current de facto standard for
sidebar-like UI objects? It seems as if this change also makes the sidebar
overly prominent in the browser window... have we done any testing with actual
users?

Updated

18 years ago
Status: VERIFIED → REOPENED

Updated

18 years ago
Assignee: slamm → german
Status: REOPENED → NEW

Comment 3

18 years ago
Sorry, this is getting too many complaints. The real estate for personal toolbar
 and location field is too valuable. Re-opening and will assign to german.

Updated

18 years ago
Resolution: INVALID → ---
(Assignee)

Comment 4

18 years ago
This is the design as currently planned. I want this design to get exposed with
the new look and feel that will go into the builds shortly. Right now with the
older design, it kind of looks not very useful. Later we can always go back and
change it if there are true usability problems (it's just three lines of XUL!).
But the point is - we already know how the conventional design works, Xul is
made for building variations. In the near future BTW you will see more such
design changes, where we are gradually trying to bring the design to the new
look and feel. And to verify the degree of usefulness it's not enough to expose
this netscape-internal or even mozilla-internal users since being mostly
developers their usage characteristics represent a small percentage of overall
netscape users.

Comment 5

18 years ago
Sounds good, just want to keep this bug open to track. I have been asked several
times if there is a bug open on this.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Here are my thoughts

1) The menubar is supposed to have a grippy, so that it can be hidden like the
toolbars (to allow users to gain a kiosk like view mode without having to
restart the program) - this was my original motivation for suggesting xpmenus.

2) The toolbar bouncing around seems an odd behaviour. Remember some people
(like me) dont even look at the toolbar so much as subconsciously move their
mouse to the place in the toolbar where they've become accustomed to clicking :)

..all of that said, German is right, its good to be able to prototype and test
ideas. I don't *hate* this design.. I just am not fond of its implementation in
Navigator. I like its implementation in Messenger far more (even though the
chrome has moved, the menubars and toolbars are bundled together, and it doesnt
look half bad). I also like the way it gives the sidebar more vertical room,
which it sort of needs, at 800x600 at least.

Comment 7

18 years ago
#1 is covered in another bug. I have a fix ready as part of my next sidebar rev.

Comment 8

18 years ago
The bug number for #1 is 14837.

Updated

18 years ago
Assignee: german → pavlov
Status: ASSIGNED → NEW

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
I just checked in a fix

Updated

18 years ago
Status: RESOLVED → REOPENED

Updated

18 years ago
Resolution: FIXED → ---

Comment 10

18 years ago
Reopening. This wasn't supposed to be "fixed" yet. Paul opened this bug to track
it.

Updated

18 years ago
Assignee: pavlov → german
Status: REOPENED → NEW

Comment 11

18 years ago
Reassigning to german.
(Assignee)

Comment 12

18 years ago
this effort is put on hold until we can see it with the new Netscape look and
feel, so we put the toolbar back under the toolbars for while we fix a whole
bunch of other css and xul problems.

Comment 13

18 years ago
Now we are in this awkward state. The sidebar is to the left of the toolbars in
mailnews, but under the toolbars in the browser. Should I make mailnews
consistent with the browser layout?
(Assignee)

Comment 14

18 years ago
yes to avoid said awkwardness for the next days mail should be made consistent
with the browser, namely the sidebar needs to get tucked under menu and
toolbars. Behaviors and look and feel should always consistent for the main app
structures. Once we get the new look and feel in we will change it back and see
how it looks.
Status: NEW → ASSIGNED

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Target Milestone: M11

Comment 15

18 years ago
Fixes have all been checked in.  Mail and Browser windows have menus and toolbar

over the sidebar.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 16

18 years ago
verified in 10/19 builds
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.