Upgrading Nightly to 57 with ClassicThemeRestorer enabled breaks UI

RESOLVED FIXED in Firefox 57

Status

()

--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: decoder, Assigned: jorgev)

Tracking

({regression})

Trunk
Firefox 57
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Posted image tabsbroken.png
If you upgrade to Nightly 57 and have CTR (ClassicThemeRestorer) addon installed (like many people have), then this will break your UI (e.g. tabs broken, toolbar not clickable). I also was not able to uninstall any extensions (maybe related to bug 940449).

We really need to test this carefully, otherwise this might break many installations. Attached is a screenshot of what I saw.

I closed the browser, moved the CTR .xpi out of my extensions directory and restarted to fix this problem.
(Assignee)

Comment 1

2 years ago
There is no expectation of legacy add-ons working well with 57. The problem is we haven't enabled yet the default disabling of those add-ons in 57.

I marked the add-on as incompatible now, to mitigate the problem, given it's popularity.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Assignee: nobody → jorge
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox57: affected → fixed
status-firefox-esr52: --- → unaffected
Target Milestone: --- → Firefox 57
You need to log in before you can comment on or make changes to this bug.