Closed Bug 1387831 Opened 2 years ago Closed 2 years ago

mochitest clipboard isn't running on windows anymore

Categories

(Taskcluster :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla57

People

(Reporter: jmaher, Assigned: Callek)

References

Details

Attachments

(3 files, 1 obsolete file)

after the migration of windows builds to taskcluster tier-1, I do not see the mochitest-clipboard job running on any of our automation anymore.
let me clarify, it doesn't run on any of our windows automation- but all other platforms are fine.
I just pushed a potential fix to try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=ae8cd4ad217ede707b2229bc42ff0890a56ba7c6

I'll attach the fix to this bug now....
Assignee: nobody → bugspam.Callek
(In reply to Geoff Brown [:gbrown] from comment #2)
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&filter-
> searchStr=mochitest-
> clipboard&fromchange=4f821dab4306fd0aff947ce55a1304acd7e4cf95&tochange=f1693d
> 664f8e8ee4c79801630c181c28095cad56

To be clear, mochi-clipboard on central is not scheduling `e10s: both` anymore, which means the e10s variant is the only one getting scheduled on try with my push right now. If we need that distinction and some runs with e10s disabled I can code it in.
Looks like this is orange on my try push, can one of you check if this is a regression from when it want running or an issue with how I'm running it?
Flags: needinfo?(jmaher)
Flags: needinfo?(gbrown)
I had a quick look and suspect this is a regression from bug 1386694 -- clipboard tries to run jetpack tests but finds there are none. Maybe Joel can say more definitively?
(In reply to Geoff Brown [:gbrown] from comment #7)
> I had a quick look and suspect this is a regression from bug 1386694 --
> clipboard tries to run jetpack tests but finds there are none. Maybe Joel
> can say more definitively?

To facilitate this thought, I've pushed to try twice.

once with the parent of Bug 1386694:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a4a9037ae138067133c64a7d4b83321a26aa8c12

And once directly ontop of Bug 1386694:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9fd674cc9b840320a1f39421141863058c74e45f
yeah, we just need to clean up the jetpack-package stuff.  I suspect this is getting picked up inside of buildbot.


for example in this log file:
https://archive.mozilla.org/pub/firefox/try-builds/Callek@gmail.com-ae8cd4ad217ede707b2229bc42ff0890a56ba7c6/try-win32/try_win7_ix_test-mochitest-clipboard-e10s-bm127-tests1-windows-build2628.txt.gz

we are running:
========= Started 'c:/mozilla-build/python27/python -u ...' warnings (results: 1, elapsed: 18 mins, 15 secs) (at 2017-08-06 12:12:17.640762) =========
'c:/mozilla-build/python27/python' '-u' 'scripts/scripts/desktop_unittest.py' '--cfg' 'unittests/win_unittest.py' '--mochitest-suite' 'plain-clipboard,chrome-clipboard,browser-chrome-clipboard,jetpack-package-clipboard' '--e10s' '--blob-upload-branch' 'try' '--download-symbols' 'ondemand'

the only references in-tree for jetpack-package-clipboard are mozharness suite names:
http://searchfox.org/mozilla-central/search?q=jetpack-package-clipboard&path=

and for buildbot-configs:
https://hg.mozilla.org/build/buildbot-configs/file/c1b905212168/mozilla-tests/config.py#l645

so some ideas:
1) create a new clipboard suite in buildbot land which has no jetpack-package-clipboard
2) remove jetpack-package-clipboard from all branches :)
3) add a blank test in jetpack-package-clipboard that has subsuite=clipboard in the manifest file

of these, I think #1 is the right solution.



as a note, the two try pushes are not showing on try- it looks like there is a bug with hg/treeherder/try
Flags: needinfo?(jmaher)
Comment on attachment 8894256 [details]
Bug 1387831 - mochitest clipboard isn't running on windows anymore.

https://reviewboard.mozilla.org/r/165348/#review170752

nice and simple- lets fix buildbot-configs first :)
Attachment #8894256 - Flags: review?(jmaher) → review+
Flags: needinfo?(gbrown)
err this time with diff headers to make things look legit to splinter/bugzilla-diff
Attachment #8895387 - Attachment is obsolete: true
Attachment #8895396 - Flags: review?(kmoir)
Attachment #8895396 - Flags: feedback?(jmaher)
Comment on attachment 8895396 [details] [diff] [review]
Buildbot patch to disable jetpack clipboard testing

Review of attachment 8895396 [details] [diff] [review]:
-----------------------------------------------------------------

::: mozilla-tests/config.py
@@ +3054,5 @@
> +            for test_type in ['opt_unittest_suites', 'debug_unittest_suites']:
> +                for test in branch['platforms'][platform][slave_platform][test_type]:
> +                   if "mochitest-clipboard" not in test[0]:
> +                       continue
> +                   test[1]['extra_args'][1] = 'plain-clipboard,chrome-clipboard,browser-chrome-clipboard'

be careful here, android just has mochitest-plain-clipboard:
http://searchfox.org/mozilla-central/source/taskcluster/ci/test/tests.yml#731

could we not be extra careful and do something like:
if 'plain-clipboard' in test[1]['extra_args'][1] and
   'chrome-clipboard' in test[1]['extra_args'][1] and
   'browser-chrome-clipboard' in test[1]['extra_args'][1]
   test[1]['extra_args'][1] = 'plain-clipboard,chrome-clipboard,browser-chrome-clipboard'
Attachment #8895396 - Flags: feedback?(jmaher) → feedback-
(In reply to Joel Maher ( :jmaher) (UTC-9) from comment #14)
> Comment on attachment 8895396 [details] [diff] [review]
> Buildbot patch to disable jetpack clipboard testing
> 
> Review of attachment 8895396 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: mozilla-tests/config.py
> @@ +3054,5 @@
> > +            for test_type in ['opt_unittest_suites', 'debug_unittest_suites']:
> > +                for test in branch['platforms'][platform][slave_platform][test_type]:
> > +                   if "mochitest-clipboard" not in test[0]:
> > +                       continue
> > +                   test[1]['extra_args'][1] = 'plain-clipboard,chrome-clipboard,browser-chrome-clipboard'
> 
> be careful here, android just has mochitest-plain-clipboard:
> http://searchfox.org/mozilla-central/source/taskcluster/ci/test/tests.yml#731
> 
> could we not be extra careful and do something like:
> if 'plain-clipboard' in test[1]['extra_args'][1] and
>    'chrome-clipboard' in test[1]['extra_args'][1] and
>    'browser-chrome-clipboard' in test[1]['extra_args'][1]
>    test[1]['extra_args'][1] =
> 'plain-clipboard,chrome-clipboard,browser-chrome-clipboard'

I could if :kim thinks it is worth it. I should note that this only changes mochi-clipboard test definitions in buildbot for OSX and Windows on trunk, there is no change to android, or any linux builders.
Comment on attachment 8894256 [details]
Bug 1387831 - mochitest clipboard isn't running on windows anymore.

https://reviewboard.mozilla.org/r/165348/#review171730
Attachment #8894256 - Flags: review+
Comment on attachment 8895396 [details] [diff] [review]
Buildbot patch to disable jetpack clipboard testing

Android code is in mozilla-tests/mobile_config.py and isn't actively used for android tests anymore since they have all migrated to taskcluster. Actually I opened bug 1388790 to remove.
Attachment #8895396 - Flags: review?(kmoir) → review+
Pushed by Callek@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8bca91c08541
mochitest clipboard isn't running on windows anymore. r=jmaher,kmoir
https://hg.mozilla.org/mozilla-central/rev/8bca91c08541
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.