Print item in hamburger panel should print instead of opening print preview (like file menu)

VERIFIED FIXED in Firefox 57

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Oriol, Assigned: maya.messinger)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 verified)

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Open Hamburguer menu. The "Print..." entry has the Ctrl+P keyboard shortcut next to it.

There is just one problem: clicking "Print..." opens Print Preview instead of showing the Print dialog. But Ctrl+P shows the Print dialog. So they do different things. This is confusing.
Whiteboard: [photon-structure] [triage]

Comment 1

2 years ago
This is ultimately a UX issue. Changing the label is not difficult. We could also hide the shortcut on Windows/Linux, like we did prior to the photon work. Aaron, thoughts?
Blocks: 1354116
Flags: needinfo?(abenson)
Summary: Hamburguer menu confuses Print with Print Preview → Hamburger menu confuses Print with Print Preview (maybe change label or don't display shortcut on Windows/Linux)
Whiteboard: [photon-structure] [triage] → [photon-structure][triage]
(Reporter)

Comment 2

2 years ago
And "Print..." should be renamed to "Print Preview" if you want to be consistent with File menu.

Comment 3

2 years ago
(In reply to Oriol [:Oriol] from comment #2)
> And "Print..." should be renamed to "Print Preview" if you want to be
> consistent with File menu.

The button in the hamburger panel always opened print preview and always just said "Print". It's not clear to me why this is suddenly an issue.

Comment 4

2 years ago
Posted image Example
The Print Menu item should not open the print preview panel on any platform. That it is different on Mac vs. Windows is a bug and should be fixed.
Flags: needinfo?(abenson)

Updated

2 years ago
Summary: Hamburger menu confuses Print with Print Preview (maybe change label or don't display shortcut on Windows/Linux) → Print item in hamburger should print instead of opening print preview (like file menu)

Updated

2 years ago
Summary: Print item in hamburger should print instead of opening print preview (like file menu) → Print item in hamburger panel should print instead of opening print preview (like file menu)
Flags: qe-verify?
Priority: -- → P3
Whiteboard: [photon-structure][triage] → [photon-structure]
Whiteboard: [photon-structure] → [reserve-photon-structure]
Priority: P3 → P4
(Assignee)

Comment 5

2 years ago
Hi, Gijs pointed me to this bug, and I'd like to look at it, I can tackle it over the weekend. I'm pretty new to Bugzilla, so if you want to wait to assign this, no worries, but I'll take a stab at it. Thanks!

Updated

2 years ago
Assignee: nobody → maya.messinger
Status: NEW → ASSIGNED
Priority: P4 → P1
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
Comment hidden (mozreview-request)
(Assignee)

Comment 7

2 years ago
Hey Gijs, it was a really simple fix, and easy to find the file. Hope the push went well, it's ready for your review, I had a thing with differences about heads when I first pulled from the main repository, but doesn't look like that affected the patch. Thanks for pointing me to this one, it went much more smoothly!

Comment 8

2 years ago
mozreview-review
Comment on attachment 8909154 [details]
Bug 1387846 change print button command to print instead of print preview on all platforms

https://reviewboard.mozilla.org/r/180728/#review185778

Looks great, thanks! I'll try to find you something else in the morning, it's a bit late here (UK). :-)
Attachment #8909154 - Flags: review?(gijskruitbosch+bugs) → review+

Comment 9

2 years ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1aaa09eb300c
change print button command to print instead of print preview on all platforms r=Gijs

Comment 10

2 years ago
Hey Maya, how comfortable are you with JS? Maybe bug 1396953 would be something you can tackle next? I tried to explain roughly what a fix could look like in bug 1396953 comment 1.
https://hg.mozilla.org/mozilla-central/rev/1aaa09eb300c
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Iteration: --- → 57.3 - Sep 19
Thanks for your work, Maya!
I have successfully reproduced this bug with Nightly 57.0a1 (2017-08-06)  on windows 10 (32-bit)

this bug is verified fix with  latest nightly 57.0a1 (2017-09-19) (32-bit)

Build ID: 20170919100405
Mozilla/5.0 (Windows NT 10.0; rv:57.0) Gecko/20100101 Firefox/57.0
QA Whiteboard: [bugday-20170920]
Status: RESOLVED → VERIFIED

Comment 14

2 years ago
Are you going to introduce a print preview button to the menu?

This change has a negative effect on UX for me.

Comment 15

2 years ago
(In reply to timbugzilla from comment #14)
> Are you going to introduce a print preview button to the menu?
> 
> This change has a negative effect on UX for me.

I'm not aware of plans to this effect. You could use the customizable print button to open print preview if you use it frequently.

Bryan, can you take a look? On non-mac, the print dialog offers no preview at all, so I'm not convinced this change is an improvement for Windows/Linux users.
Flags: needinfo?(bbell)
(In reply to :Gijs from comment #15)
> (In reply to timbugzilla from comment #14)
> > Are you going to introduce a print preview button to the menu?
> > 
> > This change has a negative effect on UX for me.
> 
> I'm not aware of plans to this effect. You could use the customizable print
> button to open print preview if you use it frequently.
> 
> Bryan, can you take a look? On non-mac, the print dialog offers no preview
> at all, so I'm not convinced this change is an improvement for Windows/Linux
> users.

FWIW, we should revert this. This item opened the print preview precisely because we didn't want an extra item for that in the panel. This was a deliberate UX decision and not a bug, as opposed to what comment 4 says.

Comment 17

2 years ago
(In reply to Dão Gottwald [::dao] from comment #16)

> FWIW, we should revert this. This item opened the print preview precisely
> because we didn't want an extra item for that in the panel. This was a
> deliberate UX decision and not a bug, as opposed to what comment 4 says.

I agree with Dão. The original mistake was to label it with the wrong key-command-tip. If we're going to have only one print entry point in the Menu, then it should start with the print preview.
Flags: needinfo?(bbell)

Updated

2 years ago
Depends on: 1401754

Comment 18

2 years ago
(In reply to bbell from comment #17)
> (In reply to Dão Gottwald [::dao] from comment #16)
> 
> > FWIW, we should revert this. This item opened the print preview precisely
> > because we didn't want an extra item for that in the panel. This was a
> > deliberate UX decision and not a bug, as opposed to what comment 4 says.
> 
> I agree with Dão. The original mistake was to label it with the wrong
> key-command-tip. If we're going to have only one print entry point in the
> Menu, then it should start with the print preview.

I filed bug 1401754 to address this.
Reproduced this bug on an affected Nightly build from 2017-08-06.

This is also verified fixed on Beta 57.0b7 (20171009192146) under Windows 10 x64, Mac OS X 10.11 and Ubuntu 16.04 x64.
status-firefox57: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.