Closed Bug 1387857 Opened 2 years ago Closed 2 years ago

Stylo: mis-handling "visibility: hidden" clicks

Categories

(Core :: CSS Parsing and Computation, defect)

57 Branch
Unspecified
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1385831

People

(Reporter: noah.duncan, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: nightly-community)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170806100257

Steps to reproduce:

go to http://pentakill.leagueoflegends.com/en_US/#  Using: 57.0a1 (2017-08-06) (64-bit)


Actual results:

Cannot click elements under "visibility: hidden" loader.  Works fine without Stylo enabled (layout.css.servo.enabled = false).


Expected results:

I should be able to click things.
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
Thank you! :)
Confirmed in Nightly 57 x64 20170806100257 @ Debian Testing.

This is different than bug 1385831 which I can fix by double pressing F12, this one not.
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Ever confirmed: true
OS: Unspecified → All
Summary: Stylo mis-handling "visibility: hidden" clicks → Stylo: mis-handling "visibility: hidden" clicks
Yeah, it's the same underlying issue though. This doesn't get fixed by showing and hiding the devtools because it's not holding directly from the body, I think.

Thanks a lot for the report! :)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: stylo-site-issues
Duplicate of bug: 1385831
You need to log in before you can comment on or make changes to this bug.