Closed Bug 1387861 Opened 2 years ago Closed 2 years ago

Dragging tabs is completely broken

Categories

(Firefox :: Tabbed Browser, defect, major)

57 Branch
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified

People

(Reporter: Oriol, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(1 file)

1. Open lots of tabs (e.g. use Ctrl+T)
2. Mousedown a tab, drag it to some side

Expected: The tab is reordered to where the mouse is.
Result: It moves to another place.

I have 500 opened tabs, with this I lose track of them and Nightly is completely unusable. This needs a quick fix or backout but 1387084.

Pushlog: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=fe13b9b9e3cea1a8d4231ae44ccdec5261c6711f&tochange=11d86d5c215907a233558afefd1eb0d20b50b7d5
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Comment on attachment 8894273 [details]
Bug 1387861 - Use _scrollbox.scrollLeft instead of scrollPosition which doesn't exist anymore, and update remaining _handleTabSelect call sites for signature change.

https://reviewboard.mozilla.org/r/165360/#review170598

r=me to unbreak stuff, but:

1) please file a bug to ensure we have better automated test coverage of this. This regression shouldn't have survived automated tests. We have automated test coverage of dnd on about:newtab (or at least, we used to before activity stream), those might be a useful template to work from as it might require synthesizing native events.
2) please file a bug to update/remove the remaining mentions of `scrollPosition` (devtools, test_mousescroll.xul). They don't look to me like they're actually still current, but we should tidy up the loose ends to be sure.
Attachment #8894273 - Flags: review?(gijskruitbosch+bugs) → review+
Component: XUL Widgets → Tabbed Browser
Product: Toolkit → Firefox
[Tracking Requested - why for this release]:
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f2df8633a4ff
Use _scrollbox.scrollLeft instead of scrollPosition which doesn't exist anymore, and update remaining _handleTabSelect call sites for signature change. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/f2df8633a4ff
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Duplicate of this bug: 1387718
Duplicate of this bug: 1388042
I'm confirming that issue is FIXED, starting since Mozilla Firefox Nightly 57.0a1 (2017-08-07), so I'm marking this bug as VERIFIED.
Severity: normal → major
Status: RESOLVED → VERIFIED
OS: Unspecified → All
QA Contact: Virtual
Hardware: Unspecified → All
Version: unspecified → 57 Branch
Duplicate of this bug: 1388324
(In reply to :Gijs from comment #4)
> 1) please file a bug to ensure we have better automated test coverage of
> this. This regression shouldn't have survived automated tests. We have
> automated test coverage of dnd on about:newtab (or at least, we used to
> before activity stream), those might be a useful template to work from as it
> might require synthesizing native events.
> 2) please file a bug to update/remove the remaining mentions of
> `scrollPosition` (devtools, test_mousescroll.xul). They don't look to me
> like they're actually still current, but we should tidy up the loose ends to
> be sure.

Dao, can you please take care of those two review comments from Gijs? Thanks.
Flags: needinfo?(dao+bmo)
Since this is fixed and verified, no need to track it for 57.
Blocks: 1434229
Flags: needinfo?(dao+bmo)
Flags: in-qa-testsuite+
You need to log in before you can comment on or make changes to this bug.