Closed Bug 1387889 Opened 2 years ago Closed 2 years ago

German 'ß' (sz) triggers save button in simple machines forum

Categories

(Firefox for Android :: Keyboards and IME, defect, P2)

54 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
fennec + ---
firefox55 --- unaffected
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: klorgfasder, Assigned: jchen)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10) AppleWebKit/537.36 (KHTML, like Gecko) Version/8.0 Safari/537.36

Steps to reproduce:

Open a post edit field (new thread / answer) on a forum powered by simple machines (http://simplemachines.org/) and type an 'ß' (german sz).
Please note: Only Firefox Mobile shows this behaviour - no other browser, may it be chrome, opera, or any other.


Actual results:

As if the 'save' button had been pressed, the form is submitted.


Expected results:

A 'ß' should appear in the textarea element.
I can reproduce this issue, by trying to post a comment on a thread from http://simplemachines.org/ (you need to create an account for this). 
With the keyboard set to German, tap the single letter 'ß' (from the autocomplete suggestions in my case).
Result: The edit form is dismissed and would be posted if the captcha is correct.

Device: LG Nexus 5 (Android 6.0.1)
Keyboards used: Gboard & SwiftKey
Build: Nightly 57 (2017-22-08)

Could not reproduce on Fennec Beta 56 or Fennec 55.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
Hi Joe, Wesly
Please help me prioritize this.
Thanks!
Flags: needinfo?(wehuang)
Flags: needinfo?(jcheng)
Assignee: nobody → nchen
tracking-fennec: ? → +
Priority: -- → P2
Some key events synthesized from strings can have modifier metastates.
For example, from the sharp S character, we synthesize an S key with Alt
metastate. However, we don't actually want to pass the Alt metastate to
Gecko because the Alt meta key is not actually pressed in this case.
Attachment #8901005 - Flags: review?(esawin)
let's go with Snorp's priority and it looks like Jim's on it
Flags: needinfo?(jcheng)
Flags: needinfo?(wehuang)
Attachment #8901005 - Flags: review?(esawin) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/20e283d11850
Don't pass along metastate of synthesized keys; r=esawin
https://hg.mozilla.org/mozilla-central/rev/20e283d11850
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8901005 [details] [diff] [review]
Don't pass along metastate of synthesized keys (v1)

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: Possible unexpected behavior when entering text, e.g. entering non-English characters could trigger unexpected site actions.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Small patch that only addresses this specific issue.
[String changes made/needed]: None
Attachment #8901005 - Flags: approval-mozilla-beta?
If we couldn't reproduce it on beta 56, are you sure we should uplift this?
Flags: needinfo?(nchen)
Sorry, I should have mentioned I was able to reproduce it on 56 Beta on my device.
Flags: needinfo?(nchen)
Comment on attachment 8901005 [details] [diff] [review]
Don't pass along metastate of synthesized keys (v1)

Fix a keyboard issue. Beta56+.
Attachment #8901005 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.