[photon] Can not move tab to the left side

RESOLVED DUPLICATE of bug 1387861

Status

()

RESOLVED DUPLICATE of bug 1387861
a year ago
a year ago

People

(Reporter: kiki, Unassigned)

Tracking

({nightly-community})

57 Branch
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

a year ago
Created attachment 8894397 [details]
ice_video_20170807-120250.mp4

I can not move the tab from right side to the left side. This seems happened if I have more than 3 tabs open.
(Reporter)

Comment 1

a year ago
I'm on OS X El Capitan and use the latest nightly (57.0a1).
Created attachment 8894404 [details]
bug-1387943

I can reproduce on Linux too. Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0 ID:20170806100257 CSet: fe6609d22dfdd710b11e3ac7773aff89f7a8d12c

Btw. if you run my video, you will notice Nightly logo flickering over the Firefox window. It's actually not a Nightly logo, it's my desktop background image. No idea why that happened, if it's Firefox bug or my DE issue.
When running mozregression, I was perfectly able to reproduce the tab "flickering" with just two tabs open, trying to move the second one to the left. Here is the result:

> 6:34.19 INFO: Narrowed inbound regression window from [933a04a9, fe6609d2] (3 revisions) to [933a04a9, b34cf908] (2 revisions) (~1 steps left)
> 6:34.19 INFO: No more inbound revisions, bisection finished.
> 6:34.19 INFO: Last good revision: 933a04a91ce3bd44b230937083a835cb60637084
> 6:34.19 INFO: First bad revision: b34cf908546b9f37f5d1b100e67dc8ef814fca7a
> 6:34.19 INFO: Pushlog:
>https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=933a04a91ce3bd44b230937083a835cb60637084&tochange=b34cf908546b9f37f5d1b100e67dc8ef814fca7a
So STR are easy:
1) Open Firefox window.
2) Have at least two tabs opened (can be any, e.g. two about:newtab).
3) Try to reorder them with mouse dragging.
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox56: --- → unaffected
Keywords: nightly-community
(Reporter)

Comment 5

a year ago
@Michal your attachment seems broken. I can not play the video nor it shows anything when I open it.
Created attachment 8894407 [details]
bug-1387943-linux-video.zip

Hmm, I see it does not play in Firefox, but when I download it, it plays in VLC. Replacing with zipped video.
Attachment #8894404 - Attachment is obsolete: true
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1387861
status-firefox56: unaffected → ---
status-firefox57: affected → ---
Seems to be fixed using Windows 7 64 bit and Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170807113452
(Reporter)

Comment 9

a year ago
For me, I still can not move the tab freely. Sometimes it allows me to move only 2 tabs to the right, or one tab to the left. The movement is inconsistent. And the overall dragging experience seems overly vivacious (seems impossible to follow the tab movement).

Build: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:57.0) Gecko/20100101 Firefox/57.0 ID:20170807100344 CSet: bb8de16ce00cb57b587a14c210ecc7505f366328
You need to log in before you can comment on or make changes to this bug.