stylo: 12.59% Stylo Servo_StyleSheet_FromUTF8Bytes_Bench (osx-cross) regression on push 81adbdebbfe38cfb2264c7adc6748c32936a41db (Tue Jul 11 2017)

RESOLVED WONTFIX

Status

()

defect
P5
normal
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: igoldan, Unassigned)

Tracking

({perf, regression})

56 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 disabled, firefox57 affected)

Details

We have detected a platform microbenchmarks regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=81adbdebbfe38cfb2264c7adc6748c32936a41db

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

 13%  Stylo Servo_StyleSheet_FromUTF8Bytes_Bench osx-cross opt      83,369.00 -> 93,861.00


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7817

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/Automated_Performance_Testing_and_Sheriffing/Platform_Microbenchmarks
Component: Untriaged → CSS Parsing and Computation
Product: Firefox → Core
:jdm I see you are the owner of bug 1352669. Can you take a look over this old regression? Looks like it persisted till now.
Flags: needinfo?(josh)
Summary: 12.59% Stylo Servo_StyleSheet_FromUTF8Bytes_Bench (osx-cross) regression on push 81adbdebbfe38cfb2264c7adc6748c32936a41db (Tue Jul 11 2017) → stylo: 12.59% Stylo Servo_StyleSheet_FromUTF8Bytes_Bench (osx-cross) regression on push 81adbdebbfe38cfb2264c7adc6748c32936a41db (Tue Jul 11 2017)
Not sure how much we care about tracking this for 56 at this point?
Version: unspecified → 56 Branch
(In reply to Ryan VanderMeulen [:RyanVM] from comment #2)
> Not sure how much we care about tracking this for 56 at this point?

We don't.
Have you got time to look over this perf regression?
Flags: needinfo?(bobbyholley)
This is part of my ongoing work to improve CSS error reporting performance. There's no particular fix to improve the benchmark performance here that is separate from that.
Flags: needinfo?(josh)
And to be clear, this regression affects stylo only, and is the result of adding error-reporting to CSS parsing (which we need to ship). So we just need to continue optimizing css parsing as well as possible, but we don't need this one to be tracked by the performance sheriffs. :-)
Flags: needinfo?(bobbyholley)
Priority: -- → P5
(In reply to Bobby Holley (:bholley) (busy with Stylo) from comment #6)
> And to be clear, this regression affects stylo only, and is the result of
> adding error-reporting to CSS parsing (which we need to ship). So we just
> need to continue optimizing css parsing as well as possible, but we don't
> need this one to be tracked by the performance sheriffs. :-)

Then it is something we should accept? This sounds like I can close this bug as WONTFIX.
Flags: needinfo?(bobbyholley)
Yeah sure.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(bobbyholley)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.