dmake/borland C (??) complaining about winsock.h missing

RESOLVED INVALID

Status

Directory
PerLDAP
P3
normal
RESOLVED INVALID
20 years ago
14 years ago

People

(Reporter: Leif Hedstrom, Assigned: Leif Hedstrom)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

20 years ago
From: Bradley Hultine <bhultin@uswest.com>


I am using gcc-2.8.1, Perl v5.004_74, and dmake.  When running dmake, it
complains about not being able to find a winsock.h
file.  I found a winsock.h include file and put it in the include directory, but
dmake still fails with the following errors:

C:\mozilla\directory\perldap>dmake
gcc -c -I/usr\include -g -O2 -DWIN32 -g -O2        -DVERSION=\"1.00\"   -DXS_VER
SION=\"1.00\"  -IC:\perl\5.00474\lib\MSWin32-x86\CORE -DUSE_SSL API.c
In file included from \usr\include\lber.h:79,
                 from API.xs:40:
\usr\include\winsock.h:69: warning: `FD_CLR' redefined
C:\perl\5.00474\lib\MSWin32-x86\CORE\sys/socket.h:202: warning: this is the loca
tion of the previous definition
\usr\include\winsock.h:74: warning: `FD_SET' redefined
C:\perl\5.00474\lib\MSWin32-x86\CORE\sys/socket.h:201: warning: this is the loca
tion of the previous definition
\usr\include\winsock.h:76: warning: `FD_ZERO' redefined
C:\perl\5.00474\lib\MSWin32-x86\CORE\sys/socket.h:204: warning: this is the loca
tion of the previous definition
\usr\include\winsock.h:78: warning: `FD_ISSET' redefined
C:\perl\5.00474\lib\MSWin32-x86\CORE\sys/socket.h:203: warning: this is the loca
tion of the previous definition
\usr\include\winsock.h:96: warning: `timercmp' redefined
C:\gcc\include\Windows32/Sockets.h:184: warning: this is the location of the pre
vious definition
\usr\include\winsock.h:97: warning: `timerclear' redefined
C:\gcc\include\Windows32/Sockets.h:185: warning: this is the location of the pre
vious definition
\usr\include\winsock.h:113: warning: `IOC_INOUT' redefined
C:\gcc\include\Windows32/Sockets.h:195: warning: this is the location of the pre
vious definition
\usr\include\winsock.h:116: warning: `_IO' redefined
C:\gcc\include\Windows32/Sockets.h:198: warning: this is the location of the pre
vious definition
\usr\include\winsock.h:118: warning: `_IOR' redefined
C:\gcc\include\Windows32/Sockets.h:203: warning: this is the location of the pre
vious definition
\usr\include\winsock.h:120: warning: `_IOW' redefined
C:\gcc\include\Windows32/Sockets.h:201: warning: this is the location of the pre
vious definition
\usr\include\winsock.h:286: warning: `IN_CLASSC' redefined
C:\gcc\include\Windows32/Sockets.h:356: warning: this is the location of the pre
vious definition
\usr\include\winsock.h:612: warning: `ENAMETOOLONG' redefined
C:\gcc\include\errno.h:81: warning: this is the location of the previous definit
ion
\usr\include\winsock.h:615: warning: `ENOTEMPTY' redefined
C:\gcc\include\errno.h:84: warning: this is the location of the previous definit
ion
In file included from \usr\include\lber.h:79,
                 from API.xs:40:
\usr\include\winsock.h:26: warning: redefinition of `u_char'
C:\gcc\include\Windows32/Sockets.h:95: warning: `u_char' previously declared her
e
\usr\include\winsock.h:27: warning: redefinition of `u_short'
C:\gcc\include\Windows32/Sockets.h:96: warning: `u_short' previously declared he
re
\usr\include\winsock.h:28: warning: redefinition of `u_int'
C:\gcc\include\Windows32/Sockets.h:97: warning: `u_int' previously declared here

\usr\include\winsock.h:29: warning: redefinition of `u_long'
C:\gcc\include\Windows32/Sockets.h:98: warning: `u_long' previously declared her
e
\usr\include\winsock.h:35: warning: redefinition of `SOCKET'
C:\gcc\include\Windows32/Sockets.h:118: warning: `SOCKET' previously declared he
re
\usr\include\winsock.h:49: redefinition of `struct Perl_fd_set'
\usr\include\winsock.h:52: redefinition of `Perl_fd_set'
C:\perl\5.00474\lib\MSWin32-x86\CORE\sys/socket.h:70: `Perl_fd_set' previously d
eclared here
\usr\include\winsock.h:54: conflicting types for `__WSAFDIsSet'
C:\gcc\include\Windows32/Sockets.h:126: previous declaration of `__WSAFDIsSet'
\usr\include\winsock.h:83: redefinition of `struct timeval'
\usr\include\winsock.h:139: redefinition of `struct hostent'
\usr\include\winsock.h:152: redefinition of `struct netent'
\usr\include\winsock.h:159: redefinition of `struct servent'
\usr\include\winsock.h:166: redefinition of `struct protoent'
\usr\include\winsock.h:249: redefinition of `struct in_addr'
\usr\include\winsock.h:299: redefinition of `struct sockaddr_in'
\usr\include\winsock.h:309: redefinition of `struct WSAData'
\usr\include\winsock.h:310: parse error before `257'
\usr\include\winsock.h:310: warning: no semicolon at end of struct or union
\usr\include\winsock.h:317: parse error before `}'
\usr\include\winsock.h:317: warning: useless keyword or type name in empty decla
ration
\usr\include\winsock.h:317: warning: empty declaration
\usr\include\winsock.h:319: warning: redefinition of `LPWSADATA'
C:\gcc\include\Windows32/Sockets.h:393: warning: `LPWSADATA' previously declared
 here
\usr\include\winsock.h:408: redefinition of `struct sockaddr'
\usr\include\winsock.h:417: redefinition of `struct sockproto'
\usr\include\winsock.h:449: redefinition of `struct linger'
\usr\include\winsock.h:702: parse error before `257'
\usr\include\winsock.h:753: warning: redefinition of `SOCKADDR'
C:\gcc\include\Windows32/Sockets.h:879: warning: `SOCKADDR' previously declared
here
\usr\include\winsock.h:754: warning: redefinition of `PSOCKADDR'
C:\gcc\include\Windows32/Sockets.h:880: warning: `PSOCKADDR' previously declared
 here
\usr\include\winsock.h:755: warning: redefinition of `LPSOCKADDR'
C:\gcc\include\Windows32/Sockets.h:881: warning: `LPSOCKADDR' previously declare
d here
\usr\include\winsock.h:757: warning: redefinition of `SOCKADDR_IN'
C:\gcc\include\Windows32/Sockets.h:883: warning: `SOCKADDR_IN' previously declar
ed here
\usr\include\winsock.h:758: warning: redefinition of `PSOCKADDR_IN'
C:\gcc\include\Windows32/Sockets.h:884: warning: `PSOCKADDR_IN' previously decla
red here
\usr\include\winsock.h:759: warning: redefinition of `LPSOCKADDR_IN'
C:\gcc\include\Windows32/Sockets.h:885: warning: `LPSOCKADDR_IN' previously decl
ared here
\usr\include\winsock.h:761: warning: redefinition of `LINGER'
C:\gcc\include\Windows32/Sockets.h:887: warning: `LINGER' previously declared he
re
\usr\include\winsock.h:762: warning: redefinition of `PLINGER'
C:\gcc\include\Windows32/Sockets.h:888: warning: `PLINGER' previously declared h
ere
\usr\include\winsock.h:763: warning: redefinition of `LPLINGER'
C:\gcc\include\Windows32/Sockets.h:889: warning: `LPLINGER' previously declared
here
\usr\include\winsock.h:765: warning: redefinition of `IN_ADDR'
C:\gcc\include\Windows32/Sockets.h:891: warning: `IN_ADDR' previously declared h
ere
\usr\include\winsock.h:766: warning: redefinition of `PIN_ADDR'
C:\gcc\include\Windows32/Sockets.h:892: warning: `PIN_ADDR' previously declared
here
\usr\include\winsock.h:767: warning: redefinition of `LPIN_ADDR'
C:\gcc\include\Windows32/Sockets.h:893: warning: `LPIN_ADDR' previously declared
 here
\usr\include\winsock.h:769: conflicting types for `FD_SET'
C:\gcc\include\Windows32/Sockets.h:895: previous declaration of `FD_SET'
\usr\include\winsock.h:770: conflicting types for `PFD_SET'
C:\gcc\include\Windows32/Sockets.h:896: previous declaration of `PFD_SET'
\usr\include\winsock.h:771: conflicting types for `LPFD_SET'
C:\gcc\include\Windows32/Sockets.h:897: previous declaration of `LPFD_SET'
\usr\include\winsock.h:773: warning: redefinition of `HOSTENT'
C:\gcc\include\Windows32/Sockets.h:899: warning: `HOSTENT' previously declared h
ere
\usr\include\winsock.h:774: warning: redefinition of `PHOSTENT'
C:\gcc\include\Windows32/Sockets.h:900: warning: `PHOSTENT' previously declared
here
\usr\include\winsock.h:775: warning: redefinition of `LPHOSTENT'
C:\gcc\include\Windows32/Sockets.h:901: warning: `LPHOSTENT' previously declared
 here
\usr\include\winsock.h:777: warning: redefinition of `SERVENT'
C:\gcc\include\Windows32/Sockets.h:903: warning: `SERVENT' previously declared h
ere
\usr\include\winsock.h:778: warning: redefinition of `PSERVENT'
C:\gcc\include\Windows32/Sockets.h:904: warning: `PSERVENT' previously declared
here
\usr\include\winsock.h:779: warning: redefinition of `LPSERVENT'
C:\gcc\include\Windows32/Sockets.h:905: warning: `LPSERVENT' previously declared
 here
\usr\include\winsock.h:781: warning: redefinition of `PROTOENT'
C:\gcc\include\Windows32/Sockets.h:907: warning: `PROTOENT' previously declared
here
\usr\include\winsock.h:782: warning: redefinition of `PPROTOENT'
C:\gcc\include\Windows32/Sockets.h:908: warning: `PPROTOENT' previously declared
 here
\usr\include\winsock.h:783: warning: redefinition of `LPPROTOENT'
C:\gcc\include\Windows32/Sockets.h:909: warning: `LPPROTOENT' previously declare
d here
\usr\include\winsock.h:785: warning: redefinition of `TIMEVAL'
C:\gcc\include\Windows32/Sockets.h:911: warning: `TIMEVAL' previously declared h
ere
\usr\include\winsock.h:786: warning: redefinition of `PTIMEVAL'
C:\gcc\include\Windows32/Sockets.h:912: warning: `PTIMEVAL' previously declared
here
\usr\include\winsock.h:787: warning: redefinition of `LPTIMEVAL'
C:\gcc\include\Windows32/Sockets.h:913: warning: `LPTIMEVAL' previously declared
 here
dmake.exe:  Error code 1, while making 'API.o'
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Priority: P1 → P3

Comment 1

20 years ago
Setting all current Open/Normal to M4.

Comment 2

20 years ago
Clearing "M" field since Directory product is not used for 5.0 specific project
bug metrics and will mess up our queries on milestones.
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv

Comment 4

14 years ago
Is this reproducable with more recent versions (gcc, perl)?
(Assignee)

Comment 5

14 years ago
Seeing there's no reponse, I'm closing this as invalid. For PerLDAP v1.5, I will
test builds with Cygwin and, if I can get hold of it, VS C++.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.