Build jobs on Windows artifact builds (--artifact in try syntax) indicate debug=False in mozinfo.json for debug builds

RESOLVED FIXED in mozilla57

Status

defect
--
major
RESOLVED FIXED
2 years ago
5 months ago

People

(Reporter: whimboo, Assigned: chmanchester)

Tracking

(Blocks 2 bugs)

unspecified
mozilla57
Unspecified
Windows
Dependency tree / graph

Details

Attachments

(1 attachment)

Please see the following build which gets run as Windows 2012 x64 debug:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d3262a6b8d386908951cfc3e9a04c0456e62fc95&selectedJob=121124235


Artifacts got uploaded to:

https://tools.taskcluster.net/groups/KwAgLnpfQOamGyAhly5wHg/tasks/MnZsjgk1S8us28jBk6Jq6g/runs/0/artifacts

mozinfo.json contains:

> "debug": false

This problem doesn't surface on other platforms, so I would assume this is related to the new TC workers on Windows 10? As such I will leave this bug in the Taskcluster product and don't move to build config yet.
Flags: needinfo?(rthijssen)
currently debugging this. one possibility could be that whatever sets WRITE_MOZINFO (https://dxr.mozilla.org/mozilla-central/rev/5322c03f4c8587fe526172d3f87160031faa6d75/python/mozbuild/mozbuild/config_status.py#122) isn't working.
after spending a bunch of time debugging this, i noticed that the job referenced above was on try.

checking the latest production build on mozilla-central (https://treeherder.mozilla.org/#/jobs?repo=try&revision=dec52a0554bce38db0c46bd705b36d5762a7d5b0&filter-searchStr=windows&selectedJob=122936159), i note that the mozinfo.debug setting is correctly set to true.

also checking the latest build on try (https://treeherder.mozilla.org/#/jobs?repo=try&revision=a32ca6c368cab02432198d54ade5c9beeb672325&filter-searchStr=windows%20debug&selectedJob=122934825), i note that the mozinfo.debug setting is correctly set to true.

i don't know if somebody fixed this since the bug was raised or if the try job referenced in comment 0 was a fluke, but i'm closing the bug as it doesn't seem to be an issue now.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(rthijssen)
Resolution: --- → FIXED
Thanks Rob. So we originally saw this via bug 1385613 not only happening on try. But the last failure is already 10 days ago. So maybe you are right that some other patch made this work now.
Blocks: 1385613
Resolution: FIXED → WORKSFORME
Duplicate of this bug: 1391172
This seems to be still visible. See bug 1391172 for details.
Status: RESOLVED → REOPENED
Flags: needinfo?(rthijssen)
Resolution: WORKSFORME → ---
Over on bug 1391172 Dao mentioned that it might be related to --artifact?
i won't get to this before monday. will leave the ni in place to remind me then.
oh, this problem caused me a lot of trouble- I was testing some patches and thought all was well until I did a --no-artifact push to try and had a bunch of leaks :(
Flags: needinfo?(rthijssen)
Summary: Build jobs on at least Windows indicate debug=False in mozinfo.json for debug builds → Build jobs on Windows artifact builds (--artifact in try syntax) indicate debug=False in mozinfo.json for debug builds
hopefully someone who understands the artifact build process can pick this up. i've had a look at what populates mozinfo.json and am none the wiser. my suspicion is that whatever updates that file during the build doesn't get run during artifact builds hence the incorrect default debug:false setting.
Chris, can you please have a look at this bug?
Blocks: 1278699
Flags: needinfo?(cmanchester)
The issue is that taskcluster builds (on windows, at least) don't pass "--custom-build-variant-cfg debug", so the logic in mozharness to replace "debug" with "debug-artifact" doesn't kick in, and we just do an opt build.
Flags: needinfo?(cmanchester)
Assignee

Updated

2 years ago
Assignee: nobody → cmanchester

Comment 13

2 years ago
mozreview-review
Comment on attachment 8899925 [details]
Bug 1388012 - Ensure a debug artifact build is done when 'debug_build' is present in the mozharness config.

https://reviewboard.mozilla.org/r/171256/#review176426
Attachment #8899925 - Flags: review?(armenzg) → review+

Comment 14

2 years ago
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2f8718989f54
Ensure a debug artifact build is done when 'debug_build' is present in the mozharness config. r=armenzg

Comment 15

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/2f8718989f54
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Component: Integration → Services
You need to log in before you can comment on or make changes to this bug.