If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sometimes new tab won't load (console shows error `addMessageListener is not defined`)

RESOLVED DUPLICATE of bug 1387852

Status

()

Firefox
Activity Streams: Newtab
RESOLVED DUPLICATE of bug 1387852
a month ago
a month ago

People

(Reporter: timdream, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

Happens to me on today's Nightly macOS Version 57.0a1 (2017-08-07) (64-bit)

ReferenceError: addMessageListener is not defined
[Learn More]
activity-stream.bundle.js:736:3
initStore
resource://activity-stream/data/content/activity-stream.bundle.js:736:3
<anonymous>
resource://activity-stream/data/content/activity-stream.bundle.js:2724:15
__webpack_require__
resource://activity-stream/data/content/activity-stream.bundle.js:20:12
<anonymous>
resource://activity-stream/data/content/activity-stream.bundle.js:66:18
<anonymous>
resource://activity-stream/data/content/activity-stream.bundle.js:1:11
STR:

1. Cmd+T


Expect result:

1. New tab content w/ onboarding overlay and button.

Actual result:

1. Blank page with only onboarding overlay and button.
2. Open DevTools console shows the error in comment 0.

Comment 2

a month ago
Sounds like bug 1387852. Is this consistently on every restart? Do you have any special sessionstore or startup prefs? Or maybe addons?
(In reply to Ed Lee :Mardak from comment #2)
> Sounds like bug 1387852. Is this consistently on every restart? Do you have
> any special sessionstore or startup prefs? Or maybe addons?

I couldn't figure out how to reproduce this reliability. Let's dup given it's the same JS error.
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1387852
You need to log in before you can comment on or make changes to this bug.