Posting to News Server attempts to contact Mail Account

VERIFIED INVALID

Status

MailNews Core
Networking: NNTP
VERIFIED INVALID
16 years ago
9 years ago

People

(Reporter: redfloyd, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

I have several accounts configured:

1 IMAP
1 POP3
2 NNTP

When I attempt to post to a NNTP server, Mozilla tries to contact the first IMAP
server for some reason (something about trying to write to the Sent folder).

Because the IMAP account is behind a firewall (need to be connected in advance
to get to it), posting seems to hang but does not fail (message posts), but it
is still hanging trying to connect to the IMAP server.

This is a sporadic error.  It may be related to the firewall that the IMAP
server is behind.  The news article does appear to post, Mozilla seems to want
to put it in the Sent folder for some reason.  It may also be related to
changing the "From" field using the drop down list.

I'm sorry I can't give better info, I hate seeing bug reports like this myself.



Reproducible: Sometimes
Steps to Reproduce:
redfloyd, can you reproduce it on 1.0RC1 ? And please add a way to reproduce it.
In Edit | Mail & Newsgroups Account Settings | Copies & Folders, what is the
setting for 'Place a copy in' under 'When sending messages, automatically'.

Thanks.
From private mail from Scott -

For the news accounts, nothing is selected.  For the IMAP and POP account, it's
the 'Sent Folder'.

Scott, this is unusual.  Usually we default to Local Folders (the Sent folder).
  Can you remember if you changed any settings, or was this an account imported
from another client, such as 4.7x?  Thanks.
(Reporter)

Comment 4

16 years ago
It might have been imported from 4.7x, but I deleted the problem account, and
then put it back later for debugging purposes.

It definitely seems to be trying to access the default account rather than local
folders.
Redfloyd - the problem isn't that News is attempting to contact your mail account.

The problem is that (for some reason) News is set to keep copies of your
outgoing News postings into your IMAP Sent folder.

I'm going to mark this worksforme for 2 reasons:

1) By default, News sends copies of outgoing postings to Sent on Local Folders.
2) Unless you left 4.x's default settings, imported, and THEN got the *bogus*
Sent on your IMAP account setting, that's a bug.

Please re-open only if/when you see #2 happening, thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

16 years ago
OK.   I've tweaked my settings anyways.  Thanks for looking.  Appreciate it.
If you can create a new News account and it's defaulting to store sent copies on
an IMAP folder, reopen this, thanks!
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.