TEST-UNEXPECTED-FAIL | /builds/slave/test/build/mozmill/testTodayPane.js | testTodayPane.js::testTodayPane

RESOLVED FIXED in 5.9

Status

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: jorgk, Assigned: jorgk)

Tracking

(Blocks: 1 bug, {intermittent-failure})

unspecified
intermittent-failure
Dependency tree / graph

Details

(Whiteboard: [Thunderbird-testfailure: Z all])

Attachments

(1 attachment)

(Assignee)

Description

a year ago
+++ This bug was initially created as a clone of Bug #1130047 +++

This just turned up right now:
TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\testTodayPane.js | testTodayPane.js::testTodayPane

Mon Aug 7, 2017, 21:51:02

https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=5c7c2710ed3a812f3adbc3f6fdb5df6060634d59

Log says:

14:44:09     INFO -  SUMMARY-PASS | testTodayPane.js::setupModule
14:44:09     INFO -  SUMMARY-PASS | testTodayPane.js::teardownTest
14:44:09     INFO -  SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\testTodayPane.js | testTodayPane.js::testTodayPane
14:44:09     INFO -    EXCEPTION: Expression "{"class":"tab-background-middle"}" returned null. Anonymous == false
14:44:09     INFO -      at: elementslib.js line 486
14:44:09     INFO -         reduceLookup elementslib.js:486 15
14:44:09     INFO -         Lookup.prototype.getNode elementslib.js:501 10
14:44:09     INFO -         MozMillController.prototype.click controller.js:527 17
14:44:09     INFO -         testTodayPane testTodayPane.js:131 5
14:44:09     INFO -         Runner.prototype.wrapper frame.js:585 9
14:44:09     INFO -         Runner.prototype._runTestModule frame.js:655 9
14:44:09     INFO -         Runner.prototype.runTestModule frame.js:701 3
14:44:09     INFO -         Runner.prototype.runTestFile frame.js:534 3
14:44:09     INFO -         runTestFile frame.js:713 3
14:44:09     INFO -         Bridge.prototype._execFunction server.js:179 10
14:44:09     INFO -         Bridge.prototype.execFunction server.js:183 16
14:44:09     INFO -         Session.prototype.receive server.js:282 3
14:44:09     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3

Would that be caused by something that landed on M-C, the range is pretty short:

M-C last good: 47248637eafa9a38dade8dc3aa6c473617
M-C first bad: fde1450a4368d04e97174e2eb00fb48901

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=47248637eafa9a38dade8dc3aa6c473617&tochange=fde1450a4368d04e97174e2eb00fb48901
Flags: needinfo?(Mozilla)
(Assignee)

Comment 1

a year ago
Richard, you cause this:
https://hg.mozilla.org/comm-central/rev/dbb2f2dcf2059211bf49c3afccb12a6422032706#l3.17
-          <xul:hbox xbl:inherits="pinned,selected,titlechanged"
-                    class="tab-background-middle"/>

Looks like the test should test for tab-line now:
+        <xul:hbox xbl:inherits="selected=visuallyselected"
+                  class="tab-line"/>
(Assignee)

Comment 2

a year ago
How do you run those tests?
mozmake SOLO_TEST=../../../calendar/test/mozmill/testTodayPane.js mozmill-one
starts the test and then it complains: collector.getModule(...) is undefined
Flags: needinfo?(makemyday)
(Assignee)

Comment 3

a year ago
Found the answer in bug 1341433 comment #0. So it's:
mozmake -C calendar/test/mozmill SOLO_TEST=testTodayPane.js mozmill-one

I have a patch that fixes this.
Flags: needinfo?(makemyday)
Flags: needinfo?(Mozilla)
(Assignee)

Comment 4

a year ago
Created attachment 8894661 [details] [diff] [review]
1388177-today-pane.patch
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8894661 - Flags: review?(Mozilla)
(In reply to Jorg K (GMT+2) from comment #1)
> Richard, you cause this:

Sorry.

Comment 6

a year ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d2b81af84925
Adapt testTodayPane.js to new square tabs. rs=bustage-fix
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
(Assignee)

Comment 7

a year ago
Needs to be a post-landing review for this trivial change.
Target Milestone: --- → 5.9
Comment on attachment 8894661 [details] [diff] [review]
1388177-today-pane.patch

Review of attachment 8894661 [details] [diff] [review]:
-----------------------------------------------------------------

Patch seems to work as to be seen on Treeherder.
Looks good, thanks for the quick fix.
Attachment #8894661 - Flags: review?(Mozilla) → review+
You need to log in before you can comment on or make changes to this bug.