Show what's new page on version change instead of based on the client being updated

RESOLVED DUPLICATE of bug 1386224

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1386224
a year ago
11 months ago

People

(Reporter: rstrong, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56blocking fixed, firefox57+ fixed)

Details

The current system is complex and fragile due to having to read and write metadata provided by the update server and this has to happen in the startup path which is something that we are trying to reduce for Quantum Perf.

Also, the current system only shows the what's new page to the user that performed the update.

It has also been decided that we will always show a what's new page after every update.

It would be much simpler to just go back to always showing the what's new page instead of using the system that was implemented so we seldom if ever showed the what's new page.
needinfoing a couple of people to ask if they think it would be ok if beta updates always had showURL so it is possible to check if there is a problem earlier in the cycle? This is one of those cases where unit tests won't cover it since it requires a real application startup sequence.
Flags: needinfo?(lhenry)
Flags: needinfo?(bhearsum)
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #1)
> needinfoing a couple of people to ask if they think it would be ok if beta
> updates always had showURL so it is possible to check if there is a problem
> earlier in the cycle? This is one of those cases where unit tests won't
> cover it since it requires a real application startup sequence.

We'd need to update our submission scripts, but I don't see any technical reason why we can't do this.
Flags: needinfo?(bhearsum)
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #0)
...
> It has also been decided that we will always show a what's new page after
> every update.

This was not the decision - the decision was instead to show the WNP after the dot-oh release and one additional dot release per cycle. Does what you're proposing here assume we want to show WNP after every major and dot release?
Flags: needinfo?(robert.strong.bugs)
It doesn't have to. My main concern can be addressed by having update advertisement from balrog on the beta channel containing showURL so any issues will be seen early in the cycle. I check beta updates which might be enough or it could be part of the QE verifications.

So, would it be ok if beta updates always had showURL so it is possible to check if there is a problem earlier in the cycle? I will have to try to figure out a different approach if not and I haven't been able to come up with a way to get around this so far.
Flags: needinfo?(robert.strong.bugs)
We should either go with this idea for 56/57, or land the changes in bug 1386224 for 56/57. We will likely still want a What's New Page on 56 so I'll mark this as a release blocker (though we could take either solution, one of them has to work for 56.)
status-firefox56: --- → affected
status-firefox57: --- → affected
tracking-firefox56: --- → blocking
tracking-firefox57: --- → +
Flags: needinfo?(lhenry)
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1386224
status-firefox56: affected → fixed
status-firefox57: affected → fixed
You need to log in before you can comment on or make changes to this bug.