If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Remove nsIPrefBranch2 and nsIPrefBranchInternal in DOMi

RESOLVED FIXED in mozilla57

Status

Other Applications
DOM Inspector
P3
normal
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
mozilla57
All
Unspecified

SeaMonkey Tracking Flags

(seamonkey2.54 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 months ago
+++ This bug was initially created as a clone of Bug #1374847 +++

nsIPrefBranch2 and nsIPrefBranchInternal are both trivial subclasses of nsIPrefBranch which exist purely for add-on compatibility.
(Assignee)

Comment 1

2 months ago
Created attachment 8894804 [details] [diff] [review]
1388275-pref2.patch

Version upgrades to current supported levels (which I think should not go beyond Fx 56). Tested with older SeaMonkey and TB versions too.
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #8894804 - Flags: review?(iann_bugzilla)

Comment 2

2 months ago
Comment on attachment 8894804 [details] [diff] [review]
1388275-pref2.patch

LGTM r=me
Attachment #8894804 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 3

2 months ago
I thought I needed to set the minimum Gecko versions too but doesn't look this way.

https://hg.mozilla.org/dom-inspector/rev/fd6400256ecdb7df0ff66675e51a6dec9088478f
https://hg.mozilla.org/dom-inspector/rev/9b13e3ad66cf993b30ba6e40e144a7d6428f43c0
Status: ASSIGNED → RESOLVED
Last Resolved: 2 months ago
status-seamonkey2.54: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.