3.08 - 947.77% sessionrestore / sessionrestore_no_auto_restore / tp5n nonmain_startup_fileio / ts_paint / ts_paint_webext (linux64, osx-10-10, windows10-64, windows7-32) regression on push 347ea0d06092d7fcd6c34e2c7ade389b0b71ae31 (Mon Aug 7 2017)

RESOLVED DUPLICATE of bug 1388078

Status

()

Toolkit
Form Manager
RESOLVED DUPLICATE of bug 1388078
2 months ago
19 days ago

People

(Reporter: igoldan, Unassigned)

Tracking

(Blocks: 1 bug, {perf, regression, talos-regression})

Trunk
perf, regression, talos-regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57 fixed)

Details

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=347ea0d06092d7fcd6c34e2c7ade389b0b71ae31

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

948%  tp5n nonmain_startup_fileio windows7-32 opt e10s     2,192.83 -> 22,975.92
  8%  sessionrestore windows10-64 opt e10s                 658.92 -> 713.58
  5%  ts_paint windows10-64 opt e10s                       717.83 -> 755.50
  5%  sessionrestore_no_auto_restore windows10-64 opt e10s 777.25 -> 814.53
  5%  ts_paint_webext linux64 pgo e10s                     960.58 -> 1,004.83
  4%  sessionrestore windows7-32 opt e10s                  747.25 -> 775.50
  3%  ts_paint osx-10-10 opt e10s                          932.46 -> 964.25
  3%  ts_paint_webext linux64 opt e10s                     1,117.46 -> 1,151.83


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=8607

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
:MattN I see you are the owner of bug 1387611. Can you look over these perf regressions, to improve?  Or are these something we should consider accepting or backing out?
Flags: needinfo?(MattN+bmo)

Updated

2 months ago
Component: Untriaged → Form Manager
Product: Firefox → Toolkit
status-firefox55: --- → unaffected
status-firefox56: --- → unaffected
status-firefox-esr52: --- → unaffected
Some of this was already filed as bug 1388078 and they all have the same root cause I think.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Flags: needinfo?(MattN+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1388078
Hi Ionuț,
Do you still see the performance regression in 57?
Flags: needinfo?(ionut.goldan)
No, these regressions don't show up on 57.
Flags: needinfo?(ionut.goldan)
Mirror the status of bug 1388078.
status-firefox57: affected → fixed
You need to log in before you can comment on or make changes to this bug.