Title Bar remains unchanged if you customize your FF

RESOLVED INVALID

Status

()

Firefox
Theme
RESOLVED INVALID
3 months ago
3 months ago

People

(Reporter: Ovidiu, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

Attachments

(1 attachment)

[Affected versions]:

Tested on Nightly 57.0a1(2017-08-07)

[Affected platforms]:

 Windows 10 x64

[Steps to reproduce]:

1. Open Firefox and open 3 tabs
2. Select the "Title Bar" from "Customize"
3. From "Themes" select another theme - please see that Title Bar color doesn't change
4. Drag a tab, previously opened at step 1, to create a new window and go to "Customize"
5. From "Themes" select a new theme.   


[Expected result]:

The new theme applies on all windows, including the Title Bar from both windows.

[Actual result]:


The Title Bar from both windows remains unchanged.  


Note: I'm not sure if this bug needs to go here or it belongs to "Toolbars and Customization" component.
Pretty sure this is a dupe of bug 1387737. Please verify against a nightly/m-c build containing a fix for that bug.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Flags: needinfo?(ovidiu.boca)
Resolution: --- → DUPLICATE
Duplicate of bug: 1387737
Created attachment 8895238 [details]
Theme - title bar bug.png

I tested with the latest Nightly that contains the fix from bug 1387737 and I still reproduce this. Please see the attached file. 
On Mac, if I change the theme, this will be applied also on Title Bar. In the attached file you can see that the Title bar remains unchanged.
Flags: needinfo?(ovidiu.boca) → needinfo?(gijskruitbosch+bugs)
On Windows, if you enable the title bar, it will be drawn by the OS. It never gets the background from the lightweight theme. This is expected, even if the behaviour on OSX is different.
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.