Closed Bug 1388328 Opened 2 years ago Closed 2 years ago

Port bug 389565 to C-C: Replace nsIExternalProtocolService::LoadUrl with nsIExternalProtocolService::LoadURI

Categories

(Thunderbird :: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 57.0

People

(Reporter: jorgk-bmo, Assigned: Paenglab)

References

Details

Attachments

(2 files, 2 obsolete files)

Summary: Port 389565 to C-C: Replace nsIExternalProtocolService::LoadUrl with nsIExternalProtocolService::LoadURI → Port bug 389565 to C-C: Replace nsIExternalProtocolService::LoadUrl with nsIExternalProtocolService::LoadURI
Attached patch Bug1388328-CPP.patch (obsolete) — Splinter Review
This are the needed changes for CPP. It builds now but it could come more.
Comment on attachment 8894858 [details] [diff] [review]
Bug1388328-CPP.patch

Build finished.
Attachment #8894858 - Flags: review?(jorgk)
Thanks, I removed some unnecessary and misleading includes. This should do it since I can't see any more in the tree.
Attachment #8894858 - Attachment is obsolete: true
Attachment #8894858 - Flags: review?(jorgk)
Attachment #8894867 - Flags: review+
Attached patch Bug1388328-JS.patch (obsolete) — Splinter Review
This is my JS part.
Attachment #8894868 - Flags: review?(jorgk)
Hmm, you have almost the same patch, only that I've changes some comments and fixed mail/test/mozmill/shared-modules/test-content-tab-helpers.js where we need to redefine loadURI since loadUrl is no longer an existing method.

Looks like we did double work here :-(

Let me land my patch in your name :-)
Comment on attachment 8894868 [details] [diff] [review]
Bug1388328-JS.patch

My patch has one important hunk more. But thanks.
Attachment #8894868 - Attachment is obsolete: true
Attachment #8894868 - Flags: review?(jorgk)
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/87a1ffd665d1
Port bug 389565 to C-C: Replace nsIExternalProtocolService::LoadUrl with nsIExternalProtocolService::LoadURI (JS part). r=jorgk
https://hg.mozilla.org/comm-central/rev/a9c3f56483a3
Port bug 389565 to C-C: Replace nsIExternalProtocolService::LoadUrl with nsIExternalProtocolService::LoadURI (CPP part). r=jorgk
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
I took a long time to compare the JS patches. There was one difference that puzzled me.

Your patch had:
@@ -215,17 +215,17 @@ var EmailAccountProvisioner = {
but after refreshing that became what my patch had originally:
@@ -223,17 +223,17 @@ var EmailAccountProvisioner = {

So why was the patch location 8 lines apart. Did you have other changes in that file not part of the patch?
Assignee: nobody → richard.marti
Target Milestone: --- → Thunderbird 57.0
> So why was the patch location 8 lines apart. Did you have other changes in that file not part of the patch?

Must be. There were/are no other recent changes in the file.
Yes, this came from the Accounts in Prefs patch.
Duplicate of this bug: 1388398
You need to log in before you can comment on or make changes to this bug.