Closed Bug 1388431 Opened 3 years ago Closed 3 years ago

[win32/64, macosx64] Devedition: mars should be signed with Nightly key

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla57

People

(Reporter: jlorenzo, Assigned: jlorenzo)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

56.0b1 build 3 showed some update errors like:

> Retrieving 'https://archive.mozilla.org/pub/devedition/candidates/56.0b1-candidates/build3/win32/en-US/Firefox Setup 56.0b1.exe' from cache...
> Found updater at updater.exe
> + '[' 0 = 1 ']'
> + 'c:\\builds\\moz2_slave\\rel-m-beta_de_w32_u_v-00000000\\scripts\\release\\updates\\update\\updater.exe' 'c:\builds\moz2_slave\rel-m-beta_de_w32_u_v-00000000\scripts\release\updates\update' 'c:\builds\moz2_slave\rel-m-beta_de_w32_u_v-00000000\scripts\release\updates\source\bin' 'c:\builds\moz2_slave\rel-m-beta_de_w32_u_v-00000000\scripts\release\updates\source\bin' 0
> ERROR: Error verifying signature.
> ERROR: Error verifying signature.
> + set +x
> PATCH DIRECTORY c:\builds\moz2_slave\rel-m-beta_de_w32_u_v-00000000\scripts\release\updates\update
> INSTALLATION DIRECTORY c:\builds\moz2_slave\rel-m-beta_de_w32_u_v-00000000\scripts\release\updates\source\bin
> WORKING DIRECTORY c:\builds\moz2_slave\rel-m-beta_de_w32_u_v-00000000\scripts\release\updates\source\bin
> failed: 19
> calling QuitProgressUI
> FAIL: update status was not successful: failed: 19
> FAIL: check_updates returned failure for WINNT_x86-msvc-x86 downloads/Firefox Setup 54.0b14.exe vs. downloads/Firefox Setup 56.0b1.exe: 1

Source: https://archive.mozilla.org/pub/devedition/tinderbox-builds/mozilla-beta-win32/release-mozilla-beta_devedition_win32_update_verify-bm73-build1-build103.txt.gz

This only concerned en-US. Ben pointed out devedition should be signed with the Nightly key. That's something we haven't done since the Windows/Mac Taskcluster Migration.

mardor confirmed en-US was signed with the release key instead. This patch will fix this.
Comment on attachment 8894982 [details]
Bug 1388431 - [win32/64, macosx64] Devedition: mars should be signed with Nightly key

https://reviewboard.mozilla.org/r/166102/#review171286
Attachment #8894982 - Flags: review?(bugspam.Callek) → review+
We're sorry, Autoland could not rebase your commits for you automatically. Please manually rebase your commits and try again.

hg error in cmd: hg rebase -s 6d54be7ec9b6 -d f5d04dc4ffb9: rebasing 412175:6d54be7ec9b6 "Bug 1388431 - [win32/64, macosx64] Devedition: mars should be signed with Nightly key r=Callek" (tip)
merging taskcluster/taskgraph/transforms/repackage_signing.py
merging taskcluster/taskgraph/transforms/signing.py
warning: conflicts while merging taskcluster/taskgraph/transforms/repackage_signing.py! (edit, then use 'hg resolve --mark')
unresolved conflicts (see hg resolve, then hg rebase --continue)
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/46b4a667c1e4
[win32/64, macosx64] Devedition: mars should be signed with Nightly key r=Callek
https://hg.mozilla.org/mozilla-central/rev/46b4a667c1e4
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
Patches from this bug solved the problem, last 56.0b1-build5 went out smoothly. Thanks for the fix :jlorenzo!
Status: RESOLVED → VERIFIED
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.