right click text in some message to copy, context menu opens under the cursor and action is executed without further click

RESOLVED INVALID

Status

Thunderbird
Message Reader UI
RESOLVED INVALID
11 months ago
10 months ago

People

(Reporter: Harry, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170612122443

Steps to reproduce:

You open a message, then you want to copy (rigth clic) a text in this message



Actual results:

The message dissapears.
What really happend was that the message was sent to recycle bin. You can search the lost message in recycle bin and restore it.
Note:  I see this behavior from the begining of the times in any version.


Expected results:

What realy should have happened is that the text must be copied to clipboard and nothing more.
Note:  I note this behavior from the begining of the times

Updated

11 months ago
Summary: When you copy (right clic) a text in some message (not all) in thunderbird, message is deleted → right click text in some message to copy, message is deleted

Comment 1

10 months ago
Please report the exact steps. Right-clicking the a message opens the context menu, nothing else.

I would just click and drag to select the desired text and then copy it.
(Reporter)

Comment 2

10 months ago
Thanks for reply and sorry for my bad english. The steps are:

1) You open a message
2) You select a text into a message
3) You right click to copy this text
4) The message is deleted

Note: Note: unfortunately it does not always happen, only with some messages (aleatory)

Comment 3

10 months ago
Hmm, we had a guy who selected text, then pressed deleted and the message was deleted. They forgot to press reply and select the text in the reply. See bug 1303285.
(Reporter)

Comment 4

10 months ago
Created attachment 8895563 [details]
relating to Bug 1388489
(Reporter)

Comment 5

10 months ago
No. That's not behavior.
I was doing tests and got a closer view of the bug resolution.
Attached is a photo so you can understand the behavior. (attachment 8895563 [details])
The problem occurs not only when you right-click a message, it also occurs in the preview.
In the attached image you can see that the mouse pointer is very close to the "delete message" option and that is exactly what causes the problem: the closer the mouse pointer is to the "delete message" option the more Chances are that the problem will occur.
If you manage to get a situation such that the mouse pointer is very close to the option "delete message" just make two or three times the right click on the selection and the message will be erased. Sometimes it is enough with the first click to delete the message unfortunately.
Sorry for the poor quality of the photo, but I could not get a screenshot without the context menu disappearing.
In Spanish the "Delete message" option is translated as "Borrar mensaje".

Comment 6

10 months ago
Yo hablo español ;-)

However, I still don't understand the problem. It sounds like you accidentally click on "Borrar mensaje". Why is the menu displayed at all while you're selecting text? You select text with the left mouse button, so that menu won't appear.

This sounds to me like a usage problem, not a software problem.
(Reporter)

Comment 7

10 months ago
Hola!!!

Como diría Quico (del Chavo del 8): pos haberlo dicho antes!!!!! jajaja.

Me voy a animar a hablarte en español para ver si me explico mejor en mi idioma natal. Perdon si incumplo alguna norma con esto (no leí aún los términos y condiciones de este sitio)

Hoy, haciendo pruebas perdí dos correos!!! pues no tomé nota del asunto y no pude encontrarlos en la papelera ya que conservan la fecha original y no la de borrado.

Definitivamente NO estoy haciendo clic accidentalmente en "Borrar mensaje". Simplemente hice un par de veces clic derecho sobre el texto seleccionado y finalmente ocurrio el problema. Obviamente muchas veces el problema se produjo en el primer clic derecho.
La condición necesaria es que el puntero del mouse esté muy cerca de la opcion "Borrar mensaje" del menu contextual y eso no ocurre siempre y depende de la ubicación del texto seleccionado en la pantalla. Incluso es posible que en la versión en inglés de thunderbird esa situación sea improbable.

Bueno y ya que me explayé mas libremente en este idioma te cuento tambien que el problema me viene ocurriendo desde hace varios años en distintas versiones de thunderbird, incluso en la version para Windows (yo utilizo Ubuntu)

Si aún asi sigo sin explicarme prometo enviar un video la proxima vez pues hoy entendí gran parte del problema y lo puedo reproducir.

Desde yá muchas gracias por ocuparte.

Comment 8

10 months ago
The forum language is English, so others can understand, so let me reply in English.

So you're saying that you select text, then do a right-click and somehow the selected option on the right-click menu is "Delete Message"/"Borrar mensaje" and that gets executed.

I will attach a few screen shots that show that on Windows, when bringing up the right-click menu, there is nothing selected and the menu always pops up either above the cursor (puntero) or below, far far away from the "Delete Message" menu entry.

Richard and Aceman: Have you ever seen on Linux (or Windows) that the context/right-click menu pops up in a position so that the cursor would be dangerously close to "Delete Message". I've never seen this. See attachment 8895563 [details].
Flags: needinfo?(richard.marti)
Flags: needinfo?(acelists)

Comment 9

10 months ago
Created attachment 8895761 [details]
Screenshot - Menu above cursor

Comment 10

10 months ago
Created attachment 8895763 [details]
Screenshot - Menu below cursor

It is possible that the menu is positioned differently on different platforms or screen sizes, even with the cursor close to "Delete Message", but that should never be executed without explicitly clicking it.
Harry, what screen resolution do you have? Or have you scaled the desktop? From your screenshot I see the context menu uses almost the full height. And you are using extensions which for example add the "Extraer..." entries above the "Etiquetar" entry. All this makes that the menu open with the "Borrar mensaje" near the cursor. I tried this in my VM with a resolution of 800*600px and got similar results with showing the menu but never deleted a message also when the menu opened under the mouse and not only at the right. Deleting a message needs at least a second action like a click. Could it be you have a setting, maybe in the mouse driver that automatically excutes an action when the mouse button is released?

Can you also try to use TB without any extension enabled (see Help menu)?
Flags: needinfo?(richard.marti)
(Reporter)

Comment 12

10 months ago
JK, exactly! Delete is executed without to do another click .
Richard, my screen resolution is 1366x768 but I used Tunderbird from several years ago and I noted this problem ever in others resolutions, also in others pc of my customers with linux or windows, always spanish version.
(Reporter)

Comment 13

10 months ago
Created attachment 8896660 [details]
The real effect!!
(Reporter)

Updated

10 months ago
Attachment #8896660 - Attachment description: The real effect → The real effect!!
(Reporter)

Comment 14

10 months ago
Hello everyone. I found the behavior that describes the bug !!!. It is not necessarily the erasure of the message. Any contextual menu option that appears underneath the mouse cursor is executed as if click was pressed when in fact this did not occur. This situation occurs whenever the cursor is far to the right and coincides with a context menu option when it appears. The more right the more likely you are. Please try it! Make a right click to the right of the window and it will happen !! I attach a video (Attachment #8896660 [details]). In this video happens that the option that is exposed is "extract to the suggested folder" which is executed without having to click.

Comment 15

10 months ago
Very strange, the menu shows up right *under* the cursor, never seen anything like it :-(
On Windows the menu *always* opens either above or below the cursor.
Summary: right click text in some message to copy, message is deleted → right click text in some message to copy, context menu opens under the cursor and action is executed without further click
(Reporter)

Comment 16

10 months ago
True. The problem occurs in linux. I just tried Windows and it's like you say. I remember that some time ago I also happened in Windows but they fixed it or the new management of windows of windows prevents that bad behavior.
(Reporter)

Comment 17

10 months ago
I will report this behavior as a new bug.

Updated

10 months ago
See Also: → bug 1389866

Comment 18

10 months ago
(In reply to Harry from comment #16)
> True. The problem occurs in linux. I just tried Windows and it's like you
> say. I remember that some time ago I also happened in Windows but they fixed
> it or the new management of windows of windows prevents that bad behavior.

I'm not seeing this problem using Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.2.1

What theme are you using in your Ubuntu? It doesn't look anything like mine.

I'm using the default Ambiance theme in Ubuntu 16.04.

Also I notice that your context menu has 27 items and mine only 22 items. Are you using an extension that adds items?

My screen resolution is 1440 x 900.
(Reporter)

Comment 19

10 months ago
Hi WlatS48. I am using Radiance theme but the bug occurs in any theme, included Ambiance. And such as I said above I saw the behavior from very years ago in different versions of linux and thunderbird, included oldest versions in windows (not the current)
(Reporter)

Comment 20

10 months ago
Well, because I noticed all of you surprised by the behavior of my thunderbird, I decided to do the following test: I created a new user in my ubuntu, I logged in with that new account and set up an email account in thunderbird. As I expected the bug did not show up!! Then the bug resides in my profile folder xxxxxxxx.default which I have been dragging for several years to keep my emails on every migration. I promise to check those files for the problem.

Comment 21

10 months ago
Glad we could help. I'm closing this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(acelists)
Resolution: --- → INVALID
(Reporter)

Comment 22

10 months ago
Hi JorgK. Thanks for your time. And thanks every body who participated in this bug.
(Reporter)

Comment 23

10 months ago
Hello everyone. I did not find the cause of the behavior, but I installed the menu wizard plugin and I was able to edit the context menu options, disable several of them and get a very small menu whose behavior is normal.
You need to log in before you can comment on or make changes to this bug.