Closed Bug 1388514 Opened 2 years ago Closed 2 years ago

Sidebar scrollbar is not clickable

Categories

(Firefox :: General, defect)

56 Branch
Unspecified
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 + fixed
firefox57 --- verified

People

(Reporter: mat, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached video Video of the issue
Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0

STR:
- Using latest nightly with Ubuntu, open the sidebar
- Make sidebar content big enough to need a scrollbar (e.g. open the history sidebar and then browse to enough pages for the scrollbar to appear)
- Try to click on the sidebar's scrollbar 

Expected results:
- Clicking on the sidebar's scrollbar is possible and the position inside the sidebar content changes accordingly

Actual results:
- Clicking on the sidebar's scrollbar is not possible. Instead, you either get a resize handle or end up clicking on the contents of the sidebar itself (in the case of the history sidebar, links)

Note: scrolling inside the sidebar with the mousewheel works fine. Clicking on the page scrollbar (or any other) instead also appears to work fine, only the sidebar's scrollbar is affected.

This is happening reliably for me using Ubuntu 16.04 LTS with the default theme and GNOME Desktop (I don't have easy access to a Mac or Windows to test there). I can *not* reproduce with Firefox 55.0.
Tested with mozregression and the problem seems to have started with https://hg.mozilla.org/mozilla-central/rev/b77dc8c1e68f from bug 1377070
Same setup, except ubuntu 17.04, no issue on my sidebar.
(In reply to Mathieu Pillard [:mat] from comment #1)
> Tested with mozregression and the problem seems to have started with
> https://hg.mozilla.org/mozilla-central/rev/b77dc8c1e68f from bug 1377070

Dão, can you take a look?
Blocks: 1377070
Flags: needinfo?(dao+bmo)
FWIW, I can reproduce, and only the leftmost pixel of the scrollbar is still clickable for me. Maybe we just need to back this out, or ensure that there's a border on the sidebar that is sufficiently large that the click target for the resizer doesn't interfere with the scrollbar.
Track 56+ as this UI behavior needs to be polished.
Duplicate of this bug: 1390690
Duplicate of this bug: 1397694
Keywords: regression
Duplicate of this bug: 1397516
This should be blocker for Firefox56, Because It is unable to scroll on Gnome Unity desktop.
Severity: normal → blocker
(In reply to Alice0775 White from comment #9)
> This should be blocker for Firefox56, Because It is unable to scroll on
> Gnome Unity desktop.

The severity field doesn't work like that.
Assignee: nobody → dao+bmo
Severity: blocker → normal
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Comment on attachment 8905536 [details]
Bug 1388514 - Make the sidebar splitter narrower again to prevent it from overlapping the scrollbar too much, and disable this behavior on Linux since scrollbars are too narrow on Ubuntu.

https://reviewboard.mozilla.org/r/177334/#review182402

r=me with a comment added.

::: browser/themes/shared/sidebar.inc.css:14
(Diff revision 1)
>    font-size: 1.333em;
>    font-weight: lighter;
>    padding: 8px;
>  }
>  
> +%ifndef MOZ_WIDGET_GTK

Can you add a % comment here explaining why we don't do this on Linux?
Attachment #8905536 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1c37a53a0c8f
Make the sidebar splitter narrower again to prevent it from overlapping the scrollbar too much, and disable this behavior on Linux since scrollbars are too narrow on Ubuntu. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/1c37a53a0c8f
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8905536 [details]
Bug 1388514 - Make the sidebar splitter narrower again to prevent it from overlapping the scrollbar too much, and disable this behavior on Linux since scrollbars are too narrow on Ubuntu.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1377070
[User impact if declined]: scrolling the sidebar is hard/impossible, because trying to drag the scrollbar resizes the sidebar instead.
[Is this code covered by automated tests?]: no, I don't think our existing test framework really allow for testing mouse interactivity with scrollbars in a way that would catch this.
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: 
1. open firefox
2. open bookmarks or history sidebar
3. ensure there's enough content there (create and copy/paste to duplicate some bookmarks, or browse to a few pages to create history) to create a vertical scrollbar (it may also help to reduce the height of the browser window)
4. try to use the scrollbar by dragging it with the mouse
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: no
[Why is the change risky/not risky?]: mostly reverting a previous patch, styling only changes.
[String changes made/needed]: nope
Attachment #8905536 - Flags: approval-mozilla-beta?
Hi Florin, could you help find someone to verify if this issue was fixed as expected on the latest Nightly build? Thanks!
Flags: qe-verify+
Flags: needinfo?(florin.mezei)
Tested on latest Nightly 57.0a1 Build ID 20170908100218 Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0 and the issue is verified-fixed and the expected requirements are met as following: 
- Now, clicking on the vertical scrollbar it's possible without any issues detected and the position inside the sidebar will change the content accordingly if dragged, using the mouse.
- The scrollbar is wide enough to not interfere with the content when focused with the mouse
- The border on the sidebar  is sufficiently large, that the click target for the resizer doesn't interfere with the scrollbar
Also, i can confirm that the issue was reproducible on Nightly 57 ID 20170808100224  Ubuntu 16.04 x 64
Looks good. Thank you
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(florin.mezei)
Version: 57 Branch → 56 Branch
Comment on attachment 8905536 [details]
Bug 1388514 - Make the sidebar splitter narrower again to prevent it from overlapping the scrollbar too much, and disable this behavior on Linux since scrollbars are too narrow on Ubuntu.

Fix a regression and was verified. Beta56+.
Attachment #8905536 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.