Storage server 401 after connecting a new account.

RESOLVED FIXED

Status

Cloud Services
Server: Firefox Accounts
RESOLVED FIXED
6 months ago
3 months ago

People

(Reporter: tcsc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
Created attachment 8895121 [details]
req/resp headers+body and sync error log

After creating a new account, syncing fails. The logs imply that everything goes fine right up to the point where I try to connect with the storage server, but the storage server gives a 401

I tried this twice with two different accounts, both with the same result, although they connected to different storage servers.

I've attached a file containing the relevant information (request and response headers for both the token request, and the request to the storage server) for one of the attempts.  The both accounts were a dummies I created to test a bug, so I don't think there's any risk that the data in the attachment could be considered sensitive. It was a @mozilla.com email (something like tchiovoloni+debug-stuff@mozilla.com), in case that's relevant.

I didn't have the same issue when connecting via stage.

Comment 1

6 months ago
Odd - I can't reproduce this with either a gmail or mozilla.com address. Thom, is it possible you had some other preference pointing at the wrong server?
(Reporter)

Comment 2

6 months ago
No (not unless something extremely weird had happened), it was a completely fresh profile, all I had done was create a sync account.

Comment 3

6 months ago
The storage server returning a body of "0" is unusual - this is basically the "unknown error" code and the only way I can see for the code to trigger it, is if the server somehow tries to send a non-json response.  Bob, can you see if there are any tracebacks in the app logs recently that might explain this issue?
Flags: needinfo?(bobm)

Comment 4

6 months ago
Bob says: "New production nodemanager had old master secret which caused 401 problem on node creation" so this should be fixed by an ops-side change.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED

Updated

3 months ago
Flags: needinfo?(bobm)
You need to log in before you can comment on or make changes to this bug.