Closed Bug 1388577 Opened 3 years ago Closed 3 years ago

Mac: Page Info window lacks a toolbar

Categories

(SeaMonkey :: Themes, enhancement, minor)

x86
macOS
enhancement
Not set
minor

Tracking

(seamonkey2.49esr fixed, seamonkey2.53 fixed, seamonkey2.54 fixed)

RESOLVED FIXED
Tracking Status
seamonkey2.49esr --- fixed
seamonkey2.53 --- fixed
seamonkey2.54 --- fixed

People

(Reporter: stefanh, Assigned: stefanh)

Details

Attachments

(1 file)

The description might be a bit misleading, but we want a unified toolbar look in the PageInfo window. I don't use PageInfo that much, but I noticed now that we lack a unified toolbar in the window... pageInfo.xul has a <windowdragbox> which currently is styled with '-moz-appearance: -moz-mac-unified-toolbar;", but that's obsolete since https://hg.mozilla.org/mozilla-central/rev/798a61cdcf78.

The trick is to use '-moz-appearance: toolbar;' instead.
One-liner, very simple.
Assignee: nobody → stefanh
Status: NEW → ASSIGNED
Attachment #8895178 - Flags: review?(frgrahl)
Comment on attachment 8895178 [details] [diff] [review]
Restore unified toolbar look

Maybe put a reference to Bug 534170 in the comment. This is what actually removed the usage from Fx.
Attachment #8895178 - Flags: review?(frgrahl) → review+
Pushed by stefanh@inbox.com:
https://hg.mozilla.org/comm-central/rev/15610850d580
Restore unified toolbar look in PageInfo window (Bug 534170 made '-moz-mac-unified-toolbar' obsolete). r=frg.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Pushed by stefanh@inbox.com:
https://hg.mozilla.org/comm-central/rev/41a1c8f12802
Restore unified toolbar look in PageInfo window (bug 1206468 made '-moz-mac-unified-toolbar' obsolete). r=frg.
Comment on attachment 8895178 [details] [diff] [review]
Restore unified toolbar look

[Approval Request Comment]
Regression caused by (bug #): bug 1206468
User impact if declined: unpolished PageInfo window
Testing completed (on m-c, etc.): nope
Risk to taking this patch (and alternatives if risky): no risk, simple css one-liner
String changes made by this patch: none
Attachment #8895178 - Flags: approval-comm-esr52?
Attachment #8895178 - Flags: approval-comm-beta?
Comment on attachment 8895178 [details] [diff] [review]
Restore unified toolbar look

a=me for c-b and c-esr
Attachment #8895178 - Flags: approval-comm-esr52?
Attachment #8895178 - Flags: approval-comm-esr52+
Attachment #8895178 - Flags: approval-comm-beta?
Attachment #8895178 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.