Closed Bug 1388679 Opened 3 years ago Closed 3 years ago

Replace other Fennec Nightly icons

Categories

(Firefox for Android :: General, defect, P1)

All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
fennec + ---
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- wontfix
firefox58 --- verified

People

(Reporter: sebastian, Assigned: jwu)

References

Details

(Whiteboard: [FNC][SPT58.1][MVP])

Attachments

(1 file)

In bug 1388291 we updated the launcher icon of Nightly versions of Fennec. There are a bunch of other Nightly icons in Fennec that we'd need to update too. Maybe we can take the time and investigate for what they are used and if they are still needed.

* icon.png (That's the one we replaced)
* large_icon.png
* launcher_widget.png (shows icon)
* widget_icon.png
* about.png (Icon + "Nightly" text)
* favicon32.png
* favicon64.png
Will this take care of the icon in the Play Store as well?  (I have no idea how that's managed.)
Flags: needinfo?(s.kaspari)
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #1)
> Will this take care of the icon in the Play Store as well?  (I have no idea
> how that's managed.)

Apparently it will be changed tomorrow. :)
Flags: needinfo?(s.kaspari)
I really hope that all of the icons will get changed soon. This looks a bit awkward: http://i.imgur.com/9yMhO9J.jpg
My icon in the URL bar is like a tradeworld icon one. Is this expected?
Blocks: 1389822
Duplicate of this bug: 1399749
tracking-fennec: --- → ?
Hi, Carol. We can discuss it next week. (also for onboarding, we need separate images for different channels)
Flags: needinfo?(hhsu)
Flags: needinfo?(chuang)
for comment 6, we can wait till Sep 26 to change them (firstrun_welcome for different channels)
Please file separate issues. This is for replacing the *nightly* logo/icon everywhere. This gets confusing if we mix all kinds of icon updates into it. :)
Carol will deliver the Nightly logo for mobile once she is back from PTO
Flags: needinfo?(hhsu)
Whiteboard: [FNC][SPT58.1][MVP]
Assignee: nobody → topwu.tw
tracking-fennec: ? → +
Priority: -- → P1
Hi Carol
The same png files for Beta and Release is done in bug 1399378
Can you help us with filese  Nightly here?
Duplicate of this bug: 1401925
Comment on attachment 8912100 [details]
Bug 1388679 - Replace Fennec Nightly icons.

https://reviewboard.mozilla.org/r/183478/#review188658
Attachment #8912100 - Flags: review?(cnevinchen) → review+
Pushed by topwu.tw@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8acabce73863
Replace Fennec Nightly icons. r=nechen
Flags: needinfo?(chuang)
https://hg.mozilla.org/mozilla-central/rev/8acabce73863
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Please request Beta approval on this when you get a chance. At least, I assume we want this to ride the 57 train to release :)
Flags: needinfo?(topwu.tw)
I've been informed designers would like to give another update for Nightly icons. Let's wait for a while, I will create another follow-up bug if icons need to be changed, otherwise request a beta approval here.
Flags: needinfo?(topwu.tw)
> Maybe we can take the time and investigate for what they are used and if they are still needed.

So all those duplicates were needed after all? :|
(In reply to Sebastian Kaspari (:sebastian) from comment #18)
> > Maybe we can take the time and investigate for what they are used and if they are still needed.
> 
> So all those duplicates were needed after all? :|

Perhaps we can remove large_icon.png since is only accessed by UnusedResourcesUtil.java, but I'm not sure if it makes any side-effect or not.

Also 'launcher_widget.png' and 'icon.png' are similar but with different size, I would discuss with :carol to see if we can adjust the widget layout to use icon.png only.

'favicon32.png' and 'favicon64.png' are both used in some about pages, the same l'm  not sure if we can just use favicon64.png for all about pages.
Blocks: 1403869
Comment on attachment 8912100 [details]
Bug 1388679 - Replace Fennec Nightly icons.

Approval Request Comment
[Feature/Bug causing the regression]:
New logo icons for 57 Nightly

[User impact if declined]:
No new logo with Photon UI

[Is this code covered by automated tests?]:
No

[Has the fix been verified in Nightly?]:
Not yet

[Needs manual test from QE? If yes, steps to reproduce]: 
Yes, check the logo on Nightly has been updated and has same icon as desktop.

[List of other uplifts needed for the feature/fix]:
None

[Is the change risky?]:
No

[Why is the change risky/not risky?]:
It just changes images, no code logic modified.

[String changes made/needed]:
No
Attachment #8912100 - Flags: approval-mozilla-beta?
Not sure I understand the point?!
Why do we want the nightly icon in the beta version?!
Flags: needinfo?(topwu.tw)
I request an uplift because of comment 16, though I didn't take a deep thought.

Hi Ryan,

Should we also uplift nightly logo icons into the beta version?
Flags: needinfo?(topwu.tw) → needinfo?(ryanvm)
If they only affect Nightly's theme and branding, probably not. Sorry, I got mixed up a bit as to what all this specific bug was updating.
Flags: needinfo?(ryanvm)
Attachment #8912100 - Flags: approval-mozilla-beta?
Verified the icons have been changed in the following places:
-launcher icon
-about pages tab & history favicon 
-widget launcher
-notifications bar
Please let me know if I missed something.
Status: RESOLVED → VERIFIED
Neither this bug nor bug 1399378 fixed the old Firefox logo on the "Mozilla Nightly" screen in the settings. In which ticket will this logo be replaced?
You need to log in before you can comment on or make changes to this bug.