Status

()

RESOLVED INVALID
a year ago
a year ago

People

(Reporter: david, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170803103147

Steps to reproduce:

Use firefox 57 nightly (or any previous recent version):

Press left ALT, which is very recent due to:
- using ALT-SHIFT to switching keyboard layouts
- using ALT-TAB to switching window

Often mistake happen due to body coordination and brain thinking faster than body doing key-presses ;-)


Actual results:

- Content of page jumped.
- Not pleasant to view page in these scenarios
- when typing into textbox (ALT-SHIFT keyboard switch) it happends that menu is triggered by letter written after ALT is pressed


Expected results:

- if there is _requirement_ to have ALT binded to menu, menu should _slide_ without affecting browser (website) content 

- also would be useful (at least in default configuration) to not have "letter shortcuts", but that's just relatively minor issue
(Reporter)

Updated

a year ago
Summary: felt ALT key behaviour → left ALT key behaviour

Comment 1

a year ago
> Press left ALT, which is very recent due to:
I don't understand this, and a bug summary including a verb would be welcome. :)

So when you only press ALT and do nothing else, the page content changes for you?
Flags: needinfo?(david)
Component: Untriaged → Keyboard Navigation
(Reporter)

Comment 2

a year ago
sorry, English is not my primary language.

Well, just press left ALT, you'll see what I'm seeing - it's behavior not a bug.

Page itself not changing, but Firefox move page to be able show line with menu. That's logical, problem is, when it often happen that you press ALT unintentionally.
Flags: needinfo?(david)
This is intentional, as a way to allow easy access to the hidden-by-default menubar.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 4

a year ago
@Dolske
Next time please be kind enough, to point, where I can fix my issues instead of explaining that it as "feature" (which it's of course and we both know it)

So, for people which will have same issues as I had:
- go to about:config
- change value ui.key.menuAccessKeyFocuses to false

So, this is SOLVED for me, in case you'll suffer by this default setting, feel free to change it :)
You need to log in before you can comment on or make changes to this bug.