Gap in italic text instead of non-ascii chars, depends on default coding pref

RESOLVED DUPLICATE of bug 300721

Status

()

Core
Internationalization
RESOLVED DUPLICATE of bug 300721
16 years ago
13 years ago

People

(Reporter: Nick Kocharhook, Unassigned)

Tracking

({intl})

Trunk
mozilla1.2beta
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
I can't figure out how to reproduce this in a more permanent fashion. I'm seeing
this on Slashdot's front page. Instead of a dash, the story

"JPG Compression -- The Bandwidth Saver"

looks like this

"JPG Compression               The Bandwidth Saver"

It's that way in both the title (which isn't an href) and the link in the story.

Selecting the text shows "The Bandwidth Saver" in the proper location, although
the improperly-positioned text doesn't move, and is in fact obscured by the part
of the selection.

I see this every time I reload /.'s front page, but I can't reproduce it
anywhere else (the story's page, the archived front page for today, when I dl
the /. front page and host it locally, etc).

I'm hoping someone can take a look at this and figure out how to reproduce this
before it leaves the /. front page.
(Reporter)

Comment 1

16 years ago
Created attachment 80227 [details]
Screenshot of the badness

Comment 2

16 years ago
WFM, XP, 2002041603.
Reporter: Please always include build ID in bug-reports.
hmm.. that's a special character, not a normal normal "-". Setting charset to
ISO-8859-15 gives "?", to Windows-1252 "-"

..tech evang?
No, since we detect the page as Windows-1252 (see page info)....

Over to intl for investigation.
Assignee: attinasi → yokoyama
Component: Layout → Internationalization
QA Contact: petersen → ruixu
(Reporter)

Comment 5

16 years ago
Doh! I know better than that!

I originally saw this on Mac OS X builds 041712 (rc1) and the 4/17 nightly.

Comment 6

16 years ago
The archived story is at
http://slashdot.org/articles/02/04/20/141235.shtml?tid=152
WFM on Linux as well (current CVS)

Updated

16 years ago
Keywords: intl

Updated

16 years ago
QA Contact: ruixu → ylong

Comment 7

16 years ago
Works for me on 04-22 Mac rc1 on Mac10.1.3.

Auto-detect this page will get iso-8859-1, even I manually set charset to
window1252 or iso-8859-15 still couldn't see the problem.

Reporter, what's your default language and font setting? do you have a detail
reproduce steps? thanks!

Comment 8

16 years ago
WFM with 20020426 on MacOSX 10.1.4
Marking as WFM.  Please reopen if someone disagrees.
cc nhotta just in case if he sees this type of bugs before.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
Verified as works for me.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

16 years ago
Created attachment 84177 [details]
Another gap.

Just FYI, this bug is still there. Here's a screenshot.

Once again, it's extant on the front page, but not any other incarnation of the
story.

Mac OS X, build 051005 (rc2)

Comment 11

16 years ago
I don't see the problem on 05-12 RC2 build / Mac 10.1.4.

Please provide detail steps or settings(language, fonts, auto-detect...etc.) if
want to re-open.
(Reporter)

Comment 12

16 years ago
OK, I've seen this bug five times in the last week. The symptoms are exactly the
same, except it's not just dashes. Apostrophes are another culpable character. I
have updated the Summary to reflect that ("Gap in text instead of punctuation
characters").

I'm using build 052918, and I see it in 1.0 and the 1.1alpha as well. (All on OS
X, of course.)

Comment 3 mentions that this occurs when the charset is UTF-8 and goes away when
it's set to 1252 or 8859. I am experiencing this as well. In fact, I can get the
problem to show up on pages that aren't the front page by changing the character
set to UTF-8. (Which I couldn't figure out how to do before.) It seems that
we're detecting the front page as UTF-8, but all the others as 1252.
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---
Summary: Gap in text instead of dash → Gap in text instead of punctuation characters

Comment 13

16 years ago
This could be Evangelism. When I accessed the URL, FizzillaCFM/2002061014 loaded
it as ISO-8859-1, and displayed the dash character correctly. When I forced
UTF-8, the problem manifested itself. According to validator.w3.org, the server
identifies no encoding, and the validator chokes on that character, too.

If that dash character is going to be sent as an unencoded entity, then the page
needs to be identified with the appropriate character set. We need to ask
Slashdot what character that's supposed to be, and in what encoding, and then if
they're actually sending the page with that encoding. I've just sent them such
an e-mail.

Comment 14

16 years ago
I got the same result(no problem when charset as iso-8859-1 bug UTF-8) as
comment above.

Confirm this in order to investigate more detail.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 15

16 years ago
indeed, changing the encoding to UTF8 causes text layout problem.
shanjian: please take a look.
Assignee: yokoyama → shanjian

Comment 16

16 years ago
The problem character is 0x96 (en-dash in win1252). This is a invalid code point
in UTF8. I guess this is related to the subsititute character used for utf8. 

reassign to ftang. 
Assignee: shanjian → ftang

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 17

16 years ago
does not make sense, mis converter character should not produce this kind of
effect. it might display as garbage but not this. 
Target Milestone: --- → mozilla1.2beta

Comment 18

15 years ago
*** Bug 171934 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Summary: Gap in text instead of punctuation characters → Gap in italic text instead of non-ascii chars, depends on default coding pref

Comment 19

15 years ago
Created attachment 114234 [details]
animated screenshot of italic gap vs text selection

I originally attached this to bug 161250, which was similar but opposite.

Although the bug often happens on Slashdot, it also happens right here on
Bugzilla -- for example, the name "Dieter Siebœrger" is screwed up in bug
161250.

Comment 20

15 years ago
*** Bug 182690 has been marked as a duplicate of this bug. ***

Comment 21

13 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → WONTFIX

Comment 22

13 years ago
Mass Re-open of Frank Tangs Won't fix debacle. Spam is his responsibility not my own
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 23

13 years ago
Mass Re-assinging Frank Tangs old bugs that he closed won't fix and had to be
re-open. Spam is his fault not my own
Assignee: ftang → nobody
Status: REOPENED → NEW

Comment 24

13 years ago
Bug 300721 has a testcase and might be the same bug.  This bug doesn't have a
testcase and I can't reproduce it using the steps in comment 0, so I can't
verify that they're the same bug.

Comment 25

13 years ago
Based on comments in bug 300721, this is the same bug.  Bug 300721 has a
testcase, so duping to the newer bug.

*** This bug has been marked as a duplicate of 300721 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.