ASSERTION: Empty string?: 'len || Type() == eCSSDeclaration || Type() == eEnum', file seamonkey-2.49.2.0_p0/work/thunderbird-52.2.0/mozilla/dom/base/nsAttrValue.cpp, line 1757

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
4 months ago
4 months ago

People

(Reporter: Martin Mokrejs, Unassigned)

Tracking

SeaMonkey 2.49 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.2.0
Build ID: 20170807121625

Steps to reproduce:

about:buildconfig
Build platform
target
x86_64-pc-linux-gnu
Build tools
Compiler 	Version 	Compiler flags
/usr/bin/x86_64-pc-linux-gnu-gcc -std=gnu99 	4.9.4 	-Wall -Wempty-body -Wignored-qualifiers -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -ggdb -pipe -maes -mpclmul -mpopcnt -mavx -march=native -mno-avx -fno-strict-aliasing -fno-math-errno -pthread -pipe
/usr/bin/x86_64-pc-linux-gnu-g++ -std=gnu++11 	4.9.4 	-Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -ggdb -pipe -maes -mpclmul -mpopcnt -mavx -march=native -mno-avx -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -O0 -fno-omit-frame-pointer
Configure options

--host=x86_64-pc-linux-gnu --target=x86_64-pc-linux-gnu --enable-application=suite --with-external-source-dir=/scratch/var/tmp/portage/www-client/seamonkey-2.49.2.0_p0/work/thunderbird-52.2.0 --enable-debug PKG_CONFIG=x86_64-pc-linux-gnu-pkg-config CC=x86_64-pc-linux-gnu-gcc CXX=x86_64-pc-linux-gnu-g++ HOST_CC=x86_64-pc-linux-gnu-gcc HOST_CXX=x86_64-pc-linux-gnu-g++ LD=x86_64-pc-linux-gnu-ld MOZ_JEMALLOC4=1 --enable-replace-malloc --enable-system-ffi --with-l10n-base=/scratch/var/tmp/portage/www-client/seamonkey-2.49.2.0_p0/work/l10n-sources --enable-default-toolkit=cairo-gtk2 --with-google-api-keyfile=/scratch/var/tmp/portage/www-client/seamonkey-2.49.2.0_p0/work/thunderbird-52.2.0/google-api-key MAKE=make XARGS=/usr/bin/xargs --enable-system-hunspell --enable-alsa --disable-crashreporter --enable-dbus --enable-extensions=default --disable-gconf --enable-gio --disable-gnomeui --disable-gold --disable-install-strip --enable-necko-wifi --enable-optimize=-O0 --enable-pie --disable-pulseaudio --enable-safe-browsing --enable-startup-notification --disable-strip --disable-system-cairo --enable-system-sqlite --disable-updater --libdir=/usr/lib64 --prefix=/usr --with-default-mozilla-five-home=/usr/lib64/seamonkey --with-intl-api --with-nspr-prefix=/usr --with-nss-prefix=/usr --with-system-bz2 --with-system-icu --with-system-jpeg --with-system-libvpx --with-system-nspr --with-system-nss --with-system-png --with-system-zlib --x-includes=/usr/include --x-libraries=/usr/lib64 --enable-calendar


Actual results:

GetDiskSpaceAvailable returned: 20098859008 bytes
Begin mail message delivery.
Abort mail message delivery.
loaded hyphenation patterns from jar:file:///usr/lib64/seamonkey/omni.ja!/hyphenation/hyph_en_US.dic
^G[6920] ###!!! ASSERTION: Empty string?: 'len || Type() == eCSSDeclaration || Type() == eEnum', file /scratch/var/tmp/portage/www-client/seamonkey-2.49.2.0_p0/work/thunderbird-52.2.0/mozilla/dom/base/nsAttrValue.cpp, line 1757
^G[6920] ###!!! ASSERTION: Empty string?: 'len || Type() == eCSSDeclaration || Type() == eEnum', file /scratch/var/tmp/portage/www-client/seamonkey-2.49.2.0_p0/work/thunderbird-52.2.0/mozilla/dom/base/nsAttrValue.cpp, line 1757
++DOMWINDOW == 65 (0x7fdca6082000) [pid = 6920] [serial = 95] [outer = 0x7fdca7125e00]

Comment 1

4 months ago
What is this bug?
Are you reporting a TB or a SM bug? tabbrowser.xml is not a source file in TB.

FRG, can you please take a look.
Flags: needinfo?(frgrahl)
(Reporter)

Comment 2

4 months ago
I am using seamonkey, but the paths point to thunderbird codebase.

Updated

4 months ago
Component: Message Reader UI → General
Product: Thunderbird → SeaMonkey
Version: 52 Branch → SeaMonkey 2.49 Branch
Sorry but can't look into this. The build options are non standard. gtk2 will be disabled for 2.49.1 and even the rest doesn't look like anything we use for official builds. The error is deep in core code and likely neither a mailnews or suite problem if there is even one. Please reopen if you can duplicate this with either a nightly or release build. Send me an email if you want my mozconfig which works for me when building on CentOS.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Flags: needinfo?(frgrahl)
Resolution: --- → INVALID
(Reporter)

Comment 4

4 months ago
Hi Frank-Rainer,
  I do not know what you mean non-standard. I passed to configure some optional arguments and it is under control of configure script to choose whichever is the supported configureation, or at least to exit and say which arguments are mutually exclusive. We can open a new bug report about the configure arguments being not properly documented.

  Anyway, I know what compile-level C(XX)FLAGS were passed to configure, sadly configure overrides some like optimization level but other than that they are respected. There is nothing wrong with them. And, I haven't seen this bug report before so it seems like a recently introduced bug. ASSERTIONs should always be fixed.
You need to log in before you can comment on or make changes to this bug.