Closed Bug 1388907 Opened 2 years ago Closed 2 years ago

Support fill="context-fill" for test pilot extensions

Categories

(Core :: SVG, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: jkt, Assigned: jkt)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Currently Testpilot and containers would like to ship with context-fill icons to match the browser chrome.

Whilst we are at it we should support @mozilla.com as voice fill uses this.

This might not be the perfect long term solution as we would like to use the signing key, however this is something we would like to uplift with minimal risk.
Assignee: nobody → jkt
Depends on: 1377302
Attachment #8895607 - Flags: review?(dao+bmo) → review?(jwatt)
Comment on attachment 8895607 [details]
Bug 1388907 - Add @mozilla.com and @testpilot- extension identifiers for SVG context-fill icons.

https://reviewboard.mozilla.org/r/166832/#review172098
Attachment #8895607 - Flags: review?(jwatt) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cf770754be29
Add @mozilla.com and @testpilot- extension identifiers for SVG context-fill icons. r=jwatt
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/cf770754be29
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8895607 [details]
Bug 1388907 - Add @mozilla.com and @testpilot- extension identifiers for SVG context-fill icons.

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: Test pilot extensions won't be able to match native icons.
[Is this code covered by automated tests?]: N/A
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: Steps to reproduce are install a an addon with context-fill, you could use the branch here: https://github.com/jonathanKingston/testpilot-containers/commit/78b5de3b44c53870b387bd978673fd0074de6907
[List of other uplifts needed for the feature/fix]: N/A
[Is the change risky?]: No
[Why is the change risky/not risky?]: It widens the exposure to context fill icons only.
[String changes made/needed]: N/A
Attachment #8895607 - Flags: approval-mozilla-beta?
Calling out that uplifting this is important for Test Pilot since we've moved our browserAction to a webExtension
Comment on attachment 8895607 [details]
Bug 1388907 - Add @mozilla.com and @testpilot- extension identifiers for SVG context-fill icons.

For test pilot. Beta56+. Should be in 56.0b3.
Attachment #8895607 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Blocks: 1396462
Component: Theme → SVG
Product: Firefox → Core
Target Milestone: Firefox 57 → ---
You need to log in before you can comment on or make changes to this bug.