If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[GREETING] mozbot should be smarter about nick changes

VERIFIED DUPLICATE of bug 135989

Status

Webtools
Mozbot
--
enhancement
VERIFIED DUPLICATE of bug 135989
16 years ago
8 years ago

People

(Reporter: Christopher Aillon (sabbatical, not receiving bugmail), Assigned: Hixie (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

The 'seen' command reporting nick changes isn't highly useful since many times,
the user was seen later on the new nick saying other things.  Usually whenever a
nick change is reported back, users check the other nick as well, and the user
has usually been spotted more recently.  This would be a great feature IMO.

Consider the following fictitious scenario:

[11:59:57] <caillon> ok, brb
[12:00:00] --- caillon is now known as caillon_away
....
[15:00:00] <caillon_away> eek, my house is on fire!!!  I better go put it out.
[15:00:02] <-- caillon_away has quit (this isn't going in a bug report is it?)
...
[20:00:00] <IRCMonkey> botbot: seen caillon?

Actual results:
    <botbot> caillon was last seen 8 hours ago, changing nick to caillon_away

Expected results:
    <botbot> caillon was last seen 5 hours ago as caillon_away, 
             saying "eek, my house is on fire!!!  I better go put it out."


Technical consideration:
- We should not go into an endless loop in the case of changing a nick back and
forth.  Once we check a nick, we should not check it again.
(Assignee)

Comment 1

16 years ago
I was thinking of dropping the nick watching code altogether. See bug 135989
comment 1.
Summary: mozbot should be smarter about nick changes → [GREETING] mozbot should be smarter about nick changes
(Assignee)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 135989 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: kerz → mozbot
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.