If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox browser broken markup. Text overflow.

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
RESOLVED WORKSFORME
a month ago
8 days ago

People

(Reporter: danilozerovmail, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a month ago
Created attachment 8895692 [details]
Screenshot

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170808170225

Steps to reproduce:

1. Downloaded Russian version of FF Developer Edition 56.0b1 (64-bit)
2. Opened setting page.
3. On the left bottom side text (Поддержка Firefox Developer Edition / Firefox Developer Edition Support) overflows the left pannel.


Actual results:

Text overflows the panel.


Expected results:

Text should not overflows the panel.

Like RLY.

Updated

a month ago
Component: Untriaged → Preferences
Can you check if this is fixed in the latest version of Firefox Nightly with the new preferences design?
Flags: needinfo?(danilozerovmail)
(Reporter)

Comment 2

a month ago
Yes, in Nightly version message displays correctly.

But the source of the problem is still there.

Buttons in preferences can change size of the pannel.
So if someone will rename one button, panel will adjust automaticly without any additional code.
However this rule still do not applies to the Help message.
If someone will change the content of Help message again, then problem will occur again. Because Help message cant adjust width of the panel like buttons do.

So, I think it's better to add some CSS rules. So it could adjust the width automaticly, like buttons do, or so it could wrap itself on the new line if it overflows.

Exapmle:
https://i.imgur.com/NBBMCGX.png
Flags: needinfo?(danilozerovmail)
Considering this is now working correctly in Nightly, it wouldn't be worth our time right now to work on a "proper" fix. In the interim since comment #2 this may have been fixed better also since we have further refined our visual redesign of Preferences for Firefox 57.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 days ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1389250
You need to log in before you can comment on or make changes to this bug.