Closed Bug 1389022 Opened 3 years ago Closed 2 years ago

"AMO Browsing for SeaMonkey" does not work any longer

Categories

(SeaMonkey :: General, defect, P2, major)

Unspecified
Windows 7

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: RainerBielefeldNG, Assigned: isaacschemm)

References

Details

(Whiteboard: [easyconfirm])

Attachments

(1 file)

Steps how to reproduce REPRODUCIBLE with official  German SeaMonkey 2.46 FINAL  (Windows NT 6.1; WOW64; rv:49.0)  Gecko/20100101 Firefox/49.0 Build 20161213183751  (Default Classic Theme)  on German WIN7 64bit: 

1. Install "AMO Browsing for SeaMonkey" from <https://addons.mozilla.org/de/seamonkey/addon/amo-browsing-for-seamonkey/> 
   for newly created test profile
2. Go to <https://addons.mozilla.org/en-us/firefox/addon/leo-dictionaries/>
  Expected: Additional Hints, link to Converter, suppressed "FF only"
            button
  Actual: Add-On does not work at all, no changes on page.

a) Also REPRODUCIBLE with unzipped installer of  official en-US SeaMonkey
   2.53a1 (NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0 
   Build 20170719015143  (Default Classic Theme) on German WIN7 64bit
b) Also see <https://github.com/lemon-juice/AMO-Browsing-for-SeaMonkey/issues/10>
c) AMO-Browsing-Add-On is essential for SeaMonkey.
d) Problem seems to be caused by changes on AMO, But I can't tell 
   what the roots of the problems might be.
Also see "http://forums.mozillazine.org/viewtopic.php?p=14759640#p14759640"!

NEW due to various confirmations.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Additional SeaMonkey related Information is missing, instead "FF only" button has reappeared
@Tony, @Isaac:
Can you help with diagnostics and/or fix?
See Also: → 1409503
It looks like AMO is doing more stuff in JavaScript after the page loads than they used to.

Adding a short setTimeout (https://github.com/IsaacSchemm/AMO-Browsing-for-SeaMonkey/tree/timeout-wait-fix) helps a bit; it works for the SeaMonkey pages, but not the Firefox ones.
Isaac contributed a fixed version 0.9.16a1 of the add-on, I curremtly am doing several tests, results tomorrow!

Assignee due to facts!
Assignee: nobody → isaacschemm
Status: NEW → ASSIGNED
I've uploaded version 0.9.16 to both GitHub and AMO.

https://github.com/lemon-juice/AMO-Browsing-for-SeaMonkey/releases/tag/v0.9.16

For AMO it still has to go through the review process.
Review has been passed, download of 0.9.16.1 is possible now, download from AMO and installation works fine, no problems observed ...

FIXED
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
What's new with Version 0.9.17b1?
(In reply to Rainer Bielefeld from comment #8)
> What's new with Version 0.9.17b1?

It adds better support for the new/mobile version of AMO: https://i.imgur.com/1oyDqU3.png

I haven't figured out yet how to post a changelog on AMO.
You need to log in before you can comment on or make changes to this bug.