If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No connection with network calendars

RESOLVED DUPLICATE of bug 1388060

Status

Calendar
General
RESOLVED DUPLICATE of bug 1388060
a month ago
18 days ago

People

(Reporter: Massimiliano Caniparoli, Unassigned)

Tracking

Lightning 5.8
x86_64
Windows 10

Details

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170808170225

Steps to reproduce:

Thunderbird just updated to 56.0b1 and Lightning to 5.8b1.
I used to have a Google Calendar and an Office 365 calendar, respectively accessed with Provider for Google Calendar and https://github.com/ExchangeCalendar/exchangecalendar, configured this way https://github.com/Ericsson/exchangecalendar/wiki/How-to-Add-Your-Calendar-to-Thunderbird


Actual results:

Today I can't access any of the calendars, and I get an error message any time I open TB.
I can't say whether it's fault of the providers (not being compatible with new TB) or the new version of Thunderbird.
I tried to remove the Office365 calendar and recreate it, but when submitting step 3 of linked configuration page I get this error
Error code: 0x80570015
Description: [Exception... "Component returned failure code: 0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]"  nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)"  location: "JS frame :: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/m.caniparoli/AppData/Roaming/Thunderbird/Profiles/nex6qk7i/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js :: createCalendar :: line 446"  data: no]

Looks like it's the same error shown for the Google Calendar on startup


Expected results:

Errors shouldn't show up and Calendars should be linked
(Reporter)

Updated

a month ago
Keywords: calendar-integration, regression
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 1

a month ago
Problem with Google Calendar might be the same as in Bug 1388060 caused by broken OAuth2 authentication in Thunderbird 56.0b1. A fix was already created that will be shipped with the next Beta build.

Are you able to connect to your Office365 calendar using the Exchange Provider in a fresh test profile that don't have Google Provider?
Flags: needinfo?(massic80)
(Reporter)

Comment 2

a month ago
Hi,
I just tried with a brand new profile and the same error shows up.
Flags: needinfo?(massic80)

Comment 3

29 days ago
Try upgrading to the latest Beta releases (Thunderbird 56.0b3, Lightning 5.8b3, Provider for Google Calendar 3.7b3) to check if connection to Google Calendar works. 

For problems with Exchange Provider I'd suggest that you search the extension homepage for support.
(Reporter)

Comment 4

29 days ago
I downloaded the latest Italian Lightning and the latest Provider from http://archive.mozilla.org/pub/calendar/lightning/candidates/5.8b3-candidates/build1/win32/ and everything looks fine.
The external extension still doesn't work and I'll notify them. Thanks!
(Reporter)

Comment 5

18 days ago
Hi,
Exchange Provider addon has been fixed and will be released with next TB.
Everything works for me now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 days ago
Keywords: calendar-integration, regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1388060
You need to log in before you can comment on or make changes to this bug.