Favicons not showing in tabs (56.0b1)

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
3 months ago
3 months ago

People

(Reporter: KotW, Unassigned)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(firefox55 unaffected, firefox56 affected)

Details

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170803103124

Steps to reproduce:

I updated FF55.0 beta branch to 56.0b1 and restarted the browser


Actual results:

Favicons are no longer displayed in tabs at all.


Expected results:

Favicons should be displayed in tabs.

Updated

3 months ago
Component: Untriaged → Tabbed Browser
Does this reproduce on a clean Firefox profile ( https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles ) ? If you go back to 55, do the favicons show up? Does this affect new tabs or only ones from your last session (if any) ?
Flags: needinfo?(kingofthe)
(Reporter)

Comment 2

3 months ago
Does not reproduce on a clean profile; I've made two new profiles - one on 55.0, and one on 56.0b1. Both work fine in 56.0b1, with favicons displaying both on restored tabs and on new ones. 

The issue affects both new and restored tabs. Downgrading back to 55 makes them visible again on my main profile.

The issue coincided with bug #1389069, which I reported to go with this one. Something about displaying icons has changed in FF56 - I only noticed the new icons on the new profile (given that they don't display at all on the old profile)!
Flags: needinfo?(kingofthe)
Do you still see this in safe mode on that old profile? Can you try using mozregression ( https://mozilla.github.io/mozregression/ ) to narrow down when this broke between 55 and 56?
Blocks: 492172
status-firefox55: --- → unaffected
status-firefox56: --- → affected
Component: Tabbed Browser → Bookmarks & History
Flags: needinfo?(kingofthe)
See Also: → bug 1389069
Whoops. So this could be related to bug 492172, but I couldn't really find many deps that got fixed for 56 - most of it got fixed for 55, and if it works in 55 and not in 56, I'm not sure why that would be. :-(
No longer blocks: 492172
(Reporter)

Comment 5

3 months ago
(In reply to :Gijs from comment #3)
> Do you still see this in safe mode on that old profile? Can you try using
> mozregression ( https://mozilla.github.io/mozregression/ ) to narrow down
> when this broke between 55 and 56?

Running the old profile in safe mode on 56.0b2 (installed over 55.0.1) brings back the favicons, both in old and new tabs. Safe mode also brings back my library as per bug #1389069. I'm not familiar with mozregression but I'll try and familiarize myself with it!

Unfortunately, there also exists the unfortunate side effect of the new betas loading an incomplete, old session for me. It refuses to load my current tabs. Makes things more difficult!
Flags: needinfo?(kingofthe)
(Reporter)

Comment 6

3 months ago
I tried mozregression, and unfortunately the bisection wizard allows me to select last good and last bad build on the basis of version only up to 55. It seems to me that if 56b was already included, it would be fairly trivial to find out what is wrong with it. 

Given that selecting dates seems to download Nightly versions, I haven't got the faintest idea about what date to shoot for in terms of this change! Any ideas?
(In reply to KotW from comment #6)
> I tried mozregression, and unfortunately the bisection wizard allows me to
> select last good and last bad build on the basis of version only up to 55.
> It seems to me that if 56b was already included, it would be fairly trivial
> to find out what is wrong with it. 
> 
> Given that selecting dates seems to download Nightly versions, I haven't got
> the faintest idea about what date to shoot for in terms of this change! Any
> ideas?

Sorry for the delay here, my bugmail for this bug got a bit lost.

https://wiki.mozilla.org/RapidRelease/Calendar lists when different releases move through the nightly/beta/release stages. In this case, I expect you'll want something like:

--good 2017-06-01 --bad 2017-08-04

(I deliberately left a few days on either side of merge dates, because I think we've been merging a bit earlier than those dates suggest - because the tool does a bisection, for finding a regression in N days it'll only take 2log(N) steps, so a few days more or less should make no difference to how long it'll take to find a culprit)
Flags: needinfo?(kingofthe)
(Reporter)

Comment 8

3 months ago
I ran a bisection on the basis of the aforementioned dates. All the builds downloaded in the range were okay on the profile. Obviously my legacy add-ons were doing all kinds of crazy things the further along the builds went, but as far as the core issue - both favicons and my bookmarks worked fine on each of them.
Flags: needinfo?(kingofthe)
(Reporter)

Comment 9

3 months ago
56.0b3 seems to have fixed this issue!
(In reply to KotW from comment #9)
> 56.0b3 seems to have fixed this issue!

OK... I guess we can mark WFM? Though it's still a bit of a mystery to me what happened to fix it...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.