If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

page either crashes the browser or renders it incorrectly

RESOLVED DUPLICATE of bug 89738

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 89738
16 years ago
16 years ago

People

(Reporter: Todd Fisher, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Component: Tech Evangelism

The page will render the text huge much larger then it should be
looking at the source of the page i found that 
there are 
<li><h2> some text
used a lot
there is a little browser detection java script at the begining but 
i think that is just for the add window.
i think the problem is with the h2's
<li><h2> some text
<li><h2> some more text 
etc..
I saw this problem on build: 2002041903
Also on ealier builds: 2002041203
Also talking irc #mozilla nd #mozillazine
builds from saturday morning april 20th 2002
builds on linux either froze or also displayed content incorrectly
(Reporter)

Comment 1

16 years ago
Created attachment 80252 [details]
i removed most of the unnecessary html but it still is being rendered incorrectly

it appears that <center> tags repeated with out being closed is causing the
page to be rendered incorrectly
(Reporter)

Comment 2

16 years ago
It appears that <center><h2> repeated with some text and not being closed is what
is causing this problem

Comment 3

16 years ago
None of the <h2> or other h tags are closed.
Mozilla seems to increment the fontsize for each unclosed tag, in the end
showing fonts ridiculously huge (one glyph becoming several pages tall etc.)
This would likely strain X and xfs on Linux for a long time, during convertion
to bitmap.

Resolving as duplicate of bug 89738 - this is considered a parser bug it seems.

*** This bug has been marked as a duplicate of 89738 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
the h2 tags are only incremented in font size if they are preceeded by an
unclosed center tag

Comment 5

16 years ago
From the "very nice testcase" in bug 89738, attachment 46036 [details]:
"However they are not closed if this second heading is withing a DIV or a CENTER"
You need to log in before you can comment on or make changes to this bug.