Closed Bug 13892 Opened 20 years ago Closed 20 years ago

related links always shows "no related links"

Categories

(SeaMonkey :: Sidebar, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: waterson, Assigned: waterson)

References

()

Details

My guess is that this is because of the ultra-fragile way that I was trying to
find the content window. slamm: could you look at my JS (LXR link in 'url'
field, above) and tell me if there's a better way to find the content window?
I see no related links if I open the folder with the +/- twisty. If I double
click on the folder, then I see related links.

Could that be it?
Status: NEW → ASSIGNED
Target Milestone: M11
No that's a separate bug (I'll go file it...)

The problem is that it doesn't seem to ever get the document's URL, so the
related links that get shown are _always_ the five default links (e.g., "no
related links found", "search on 'www.mozilla.org'", etc.)
Chris, instead of:
    var ContentWindow = window.parent.parent.frames[1];
try
    var ContentWindow = window.content;
Yay! That worked.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
*** Bug 13918 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
this is working with 9/24 builds, no crashes closing related links even. Ship
it.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.